Mailinglist Archive: opensuse-buildservice (216 mails)

< Previous Next >
Re: [opensuse-buildservice] "BuildRequires: ant" causes "have choice for java-devel"
  • From: Michal Vyskocil <mvyskocil@xxxxxxx>
  • Date: Wed, 17 Mar 2010 14:20:05 +0100
  • Message-id: <201003171420.05722.mvyskocil@xxxxxxx>
On Wednesday 17 March 2010 04:58:50 am Douglas Hubler wrote:
When i include ant, i get build error
have choice for java-devel needed by ant: java-1.6.0-sun-devel
java-1.4.2-gcj-compat-devel java-1.6.0-openjdk-devel

I've tried specifying a specific java in *my* spec file
BuildRequires: java-1.6.0-sun

and listing it *before* the "BuildRequires: ant" but it still leads to
the same error because it's ant that is complaining. Is there anyway
to force a particular java globally? or restrict other packages from
being an option?


Add a Prefer: java-1.6.0-openjdk-devel into prjconf (osc meta prjconf $PROJECT
-e), so BS will prefer one of the SDK.

Regards
Michal Vyskocil
< Previous Next >
References