Mailinglist Archive: opensuse-buildservice (260 mails)

< Previous Next >
Re: [opensuse-buildservice] osc 0.123 incompatible with obs-server 1.6?
On Wed, 2009-12-02 at 10:45 -0600, Adrian Schröter wrote:
Am Mittwoch, 2. Dezember 2009 16:29:54 schrieb Luke Imhoff:
I've been testing out upgrading our internal copy of osc to 0.123 to get
python-keyring support, but I've hit a snag when calling osc build with
the --prefer-pkgs flag. The flag appears to package the build
description into a cpio file, but obs-server 1.6 gives a parse error
when this happens. What is the latest version of osc that is compatible
with 1.6 when using the --prefer-pkgs flag or is a stable version of the
server available that supports the cpio format?

Only the svn version (upcomming 1.7) is supporting this.

On one hand this not good to break this support, on the other hand using
--prefer-pkg could never work without bugs with 1.6 server without this
support.

So I am quite unsure if you don't have to life with that until 1.7. (or maybe
we need introduce a config option to disable the cpio upload, but only with
warnings).

bye
adrian


I can either take out the cpio upload in osc or port just the cpio
upload handling from 1.7 back to 1.6. Does the cpio upload handling
depend on anything in 1.7 beside what's in revision 8071?

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >