Mailinglist Archive: opensuse-buildservice (311 mails)

< Previous Next >
Re: [opensuse-buildservice] build 2009.07.27 doesn't detect pre-existing Ubuntu installs
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Mon, 9 Nov 2009 19:47:38 +0100
  • Message-id: <200911091947.38205.adrian@xxxxxxx>
Am Montag, 9. November 2009 19:16:32 schrieb Adrian Schröter:
Am Montag, 9. November 2009 18:52:11 schrieb Adrian Schröter:
Am Montag, 9. November 2009 17:47:11 schrieb Luke Imhoff:
When building against xUbuntu_9.10 using build-2009.07.27, it keeps
reinstall all the .debs. Do .deb based workareas not have detection
that packages are already installed in the chroot like .rpm based
chroots do? Or do I need to upgrade to a newer build? We're still
using OBS 1.5 for the server, so I didn't want to upgrade build if it
might break compatibility.

It worked latetly for me. You may try to upgrade osc and esp. the build
script first on your workstation to test again.

okay, I was wrong here. This is currently not supported by the build
script. A partial fix is in svn now, but it is not complete.

And another sorry, there is currently to much missing to make this cleanly
working. This is not that easy to fix for me, because I have not enough clue
about debs.

If you like to implement support for this, have a look into the
init_buildsystem script of build package.

You need to extend the validate_cache_file funcaiton in first place, to
generate also .id files from the deb meta data. I dunno what makes sense as
unique identifier for debs repositories.

bye
adrian

--

Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >