Mailinglist Archive: opensuse-buildservice (248 mails)

< Previous Next >
[opensuse-buildservice] [Regression] Debian Build-Depends expansion with alternates "|"
  • From: David Greaves <david@xxxxxxxxxxxx>
  • Date: Thu, 22 Oct 2009 20:52:00 +0100
  • Message-id: <4AE0B7E0.6000808@xxxxxxxxxxxx>
I think a recent change to OBS results in a failure to handle some
Build-Depends: in debian packages.

In the .dsc having:
Build-Depends: <<snip>> lzma, binutils (>= 2.19.1) | binutils-multiarch (>=
2.19.1), <<snip>>

Results in
nothing provides binutils >= 2.19.1 | binutils-multiarch >= 2.19.1

See:
Maemo:Mer:Tools:cross:gcc-4.3-test gcc-4.3

removing the "| binutils-multiarch (>= 2.19.1)" fixes the problem.

(Nb this is actually a pristine Ubuntu package AFAIR and it's been building just
fine for a while)

David

--
"Don't worry, you'll be fine; I saw it work in a cartoon once..."
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups