Mailinglist Archive: opensuse-buildservice (248 mails)

< Previous Next >
Re: [opensuse-buildservice] version resolution problem
  • From: MasterPatricko <masterpatricko@xxxxxxxxx>
  • Date: Wed, 14 Oct 2009 17:28:10 +0100
  • Message-id: <4AD5FC1A.9020204@xxxxxxxxx>
Robert Schweikert wrote:

I am having a version resolution problem in that my spec file triggers
the following error message:

Building perl-Test-ClassAPI.spec for openSUSE_11.1/x86_64
Getting buildinfo from server
buildinfo is broken... it says:
expansion error: nothing provides perl-Class-Inspector >= 1.23

The project is home:rjschwei:perl-test-classapi

The spec file contains the following tags:

Requires: perl-Class-Inspector >= 1.23
BuildRequires: perl-Class-Inspector >= 1.23

I have added
<path repository="openSUSE_11.1" project="devel:languages:perl"/>

to the meta data and according to

the Class-Inspector package is at version 1.23, something confirmed
based on the package installed on my system:

-> rpm -qa | grep perl | grep Class-Inspector

What am I missing here?

Help is much appreciated.

Looking at your spec file you actually seem to have two lines:
BuildRequires: perl-Class-Inspector >= 1.23
BuildRequires: perl-Class-Inspector >= 2.12
and of course the second one cannot be satisfied. Try removing that
second line and see what the build system says.

As an aside your repository layout seems odd, IIRC you are building all
these packages to eventually be able to build perlcritic. Dependencies
should ideally be also in the same project as the final perlcritic
package, otherwise you will end up linking to them again to build
perlcritic. Having one package per repository seems exceedingly
inefficient ...


To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups