Mailinglist Archive: opensuse-buildservice (171 mails)

< Previous Next >
[opensuse-buildservice] What is better? Expansion error or disabled?
  • From: Matthias Fehring <buschmann@xxxxxxxxxxxxxxxxxx>
  • Date: Tue, 1 Sep 2009 13:03:01 +0200
  • Message-id: <200909011303.06626.buschmann@xxxxxxxxxxxxxxxxxx>
Hello list,

I mantain packages in KDE:KDE4:Community, KDE:KDE4:Playground and
KDE:Community. Not all of these
packages work on all versions of KDE (especially those for KDE4), because of
API changes and such
things. Till now I disabled the building for those repos for that package. But
I think it would be
better, to mention it in the BuildRequires, what minimal version is needed and
to receive therefore
an expansion error for repos, that can not provide this version. So, everybody
can see, why the
package will not be built for that repo. Or is that a poor solution?

Best greetings
Buschmann

----------------------------------------------------------------------------------
openSUSE Member - de.opensuse.org Sys-Op
http://en.opensuse.org/User:Buschmann23
http://en.opensuse.org/How_to_Participate
http://en.opensuse.org/Geeko_wants_you!
< Previous Next >
This Thread
  • No further messages