Mailinglist Archive: opensuse-buildservice (262 mails)

< Previous Next >
[opensuse-buildservice] How to debug when "OpenSUSE Webclient Error" occured ?
  • From: Jian Lee <lijian.gnu@xxxxxxxxx>
  • Date: Thu, 27 Aug 2009 11:13:29 +0800
  • Message-id: <7hwqaqzq.fsf@xxxxxxxxx>

Hi, guys

I've setup obs-server on CentOS platform from
obs-server-1.6.0-14.1.src.rpm owned by openSUSE 10.

Configure mysql database, Tune the IP interface to LAN :
-----------------------------
# grep { /etc/lighttpd/vhosts.d/obs.conf
$HTTP["host"] =~ "172.16.70.30\.?" {
$SERVER["socket"] == "172.16.70.30:81\.?" {
$SERVER["socket"] == "172.16.70.30:82\.?" {
===========================================

Then Use the "Admin"/"opensuse" as Username/Password to login. First time
no error occured, but now It has "OpenSUSE Webclient Error" when i
login 172.16.70.30 (http://172.16.70.30/home) :

---------------------------------------------------------
Error Details:
Errorcode: unknown
Message: <?xml version="1.0" encoding="iso-8859-1"?> <!DOCTYPE html PUBLIC
"-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd";> <html
xmlns="http://www.w3.org/1999/xhtml"; xml:lang="en" lang="en"> <head> <title>404
- Not Found</title> </head> <body> <h1>404 - Not Found</h1> </body> </html>

Exception from Webclient:
ActiveXML::Transport::NotFoundError: <?xml version="1.0"
encoding="iso-8859-1"?> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0
Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd";>
<html xmlns="http://www.w3.org/1999/xhtml"; xml:lang="en" lang="en"> <head>
<title>404 - Not Found</title> </head> <body> <h1>404 - Not Found</h1> </body>
</html>
Stack Trace:

/srv/www/obs/common/lib/activexml/transport.rb:543:in `handle_response'
/srv/www/obs/common/lib/activexml/transport.rb:534:in `http_do'
/srv/www/obs/common/lib/activexml/transport.rb:346:in `find'
/srv/www/obs/common/lib/activexml/base.rb:69:in `find'
/srv/www/obs/webclient/app/controllers/application.rb:116:in `basic_auth'
/srv/www/obs/webclient/app/controllers/application.rb:74:in `authorize'
....
====================================================================

Did anyone have ideas ?

Thanks, all

--

Jian Lee
Chinese Blog : http://jianlee.ylinux.org
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups