Mailinglist Archive: opensuse-buildservice (213 mails)

< Previous Next >
[opensuse-buildservice] dead-lock in BS (error saving package: value of develpackage, ...)
  • From: Petr Mladek <pmladek@xxxxxxx>
  • Date: Tue, 30 Jun 2009 10:43:49 +0200
  • Message-id: <200906301043.49435.pmladek@xxxxxxx>
Hi,

I am completely lost!!!

I tried to upload OOo-3.1.1-alpha2 sources into the project
OpenOffice_org:UNSTABLE. I got many curious errors like:

--- cut ---
Checking OpenOffice_org-bootstrap...
Sending ooo310-m14-bootstrap.tar.bz2
Sending ooo-build-3.1.0.98.2.tar.gz
Sending OpenOffice_org-bootstrap.changes
Sending OpenOffice_org-bootstrap.spec
Deleting ooo-build-3.1.0.98.1-kde4-subpackage.diff
Deleting ooo-build-3.1.0.98.1.tar.gz
Deleting ooo310-m13-bootstrap.tar.bz2
Server returned an error: HTTP Error 400: Bad Request
error saving package: value of develpackage has to be a existing package
(packag
e 'OpenOffice_org-bootstrap' does not exist)
Transmitting file data
--- cut ---

Why? 'OpenOffice_org-bootstrap' exists. In
addition, 'OpenOffice_org-bootstrap-devel' does not exists, so what is it
complaining about?

--- cut ---
Checking OpenOffice_org-libs-core...
Sending ooo310-m14-libs-core.tar.bz2
Sending OpenOffice_org-libs-core.changes
Sending OpenOffice_org-libs-core.spec
Deleting ooo310-m13-libs-core.tar.bz2
Server returned an error: HTTP Error 400: Bad Request
error saving package: value of develpackage has to be a existing package
(packag
e 'OpenOffice_org-libs-core' does not exist)
Transmitting file data
--- cut ---

Both OpenOffice_org-libs-core and OpenOffice_org-libs-core-devel exists. Why
is it complaining?


!!!! IMPORTANT: !!!!

I uploaded all the package sources in a script. The second package source
was "OpenOffice_org-artwork". It is a really ugly package. Only
the "OpenOffice_org-artwork-devel" package exists. It is possible that it
caused everything.

Why are not allowed -devel-only packages?

Why did it blocke the other packages?


------

It is even worse. The packages got broken. I am not able to commit them again
because they are not longer up-to-date (according to osc). I am not able to
check out the older version, for example:

--- cut ---
pmladek@walk:/prace/OOo/bs> osc co
OpenOffice.org\:UNSTABLE/OpenOffice_org-boots
A OpenOffice.org:UNSTABLE/OpenOffice_org-bootstrap
A
OpenOffice.org:UNSTABLE/OpenOffice_org-bootstrap/OpenOffice_org-bootstrap-r
A
OpenOffice.org:UNSTABLE/OpenOffice_org-bootstrap/OpenOffice_org-bootstrap.c
A
OpenOffice.org:UNSTABLE/OpenOffice_org-bootstrap/OpenOffice_org-bootstrap.s
A
OpenOffice.org:UNSTABLE/OpenOffice_org-bootstrap/ooo-build-3.0.0.10-extensi
Server returned an error: HTTP Error 404: Not Found
ooo-build-3.1.0.98.1-kde4-subpackage.diff: no such file
--- cut ---

Well, it helps to remove any file by the UI, to unblock this
no-such-file-error. But I am still not able to commit new version.

I tried to add fake -artwork package to make it happy but I am not able to
sommit it into BS.

It looks like a real deadlock.

Could you please help me?


--
Best Regards,

Petr Mladek
software developer
---------------------------------------------------------------------
SUSE LINUX, s. r. o. e-mail: pmladek@xxxxxxx
Lihovarská 1060/12 tel: +420 284 028 952
190 00 Prague 9 fax: +420 284 028 951
Czech Republic http://www.suse.cz/

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups