Mailinglist Archive: opensuse-buildservice (213 mails)

< Previous Next >
Re: [opensuse-buildservice] Versions in prjconf Substitute
  • From: Lubos Lunak <l.lunak@xxxxxxx>
  • Date: Mon, 29 Jun 2009 15:24:01 +0200
  • Message-id: <200906291524.01106.l.lunak@xxxxxxx>
On Monday 29 of June 2009, Michael Schroeder wrote:
On Sat, Jun 27, 2009 at 12:22:31PM +0200, Lubos Lunak wrote:
It clearly knows about the versions, but it strips them away for
whatever reason, which I don't understand, since if I want at least a
certain version of something, I don't really care what the exact name of
the package is.

There is no magic crystal ball involved which tells the system that
the substituted packages use the same versioning scheme.

There doesn't need to be one in 99% of cases. If I want KDE libraries at
least version 4.2, it doesn't matter if the package is called libkde4,
kdelibs or kdelibs4, the required version is always 4.2 or more.

In those 1% cases that possibly might need it the magic crystal ball can be
the packager who can handle it manually if the need arises. There's no need
to break this for the majority just because it might possibly break. It may
break this way too.

If you really want the versions, don't rely on the substitute
feature.

What is the point of it then? I can then do the substituting myself as well.
This middle ground makes no sense and just takes away the convenience of
having one .spec for all rpm distributions.

--
Lubos Lunak
KDE developer
--------------------------------------------------------------
SUSE LINUX, s.r.o. e-mail: l.lunak@xxxxxxx , l.lunak@xxxxxxx
Lihovarska 1060/12 tel: +420 284 028 972
190 00 Prague 9 fax: +420 284 028 951
Czech Republic http://www.suse.cz
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >