Mailinglist Archive: opensuse-buildservice (213 mails)

< Previous Next >
Re: [opensuse-buildservice] osc build -p broken
  • From: Luke Imhoff <luke@xxxxxxxx>
  • Date: Mon, 22 Jun 2009 08:10:46 -0500
  • Message-id: <4A3F82D6.7060404@xxxxxxxx>
Is there any chance of the patch being integrated? For our local OBS we have a use case of being able to use osc -p with older rpms that need the -p to match the Requires/BuildRequires correctly as they can differ from the current buildinfo's requirements.

Marcus Hüwe wrote:
On 2009-06-20 21:40:58 +0000, Christian wrote:
<SNIP>
If I then want to build a pkg that depends on perl-Test-Deep, I get
admin@obs:~/OBS/devel:languages:perl/perl-Test-Base> oscb_11
GET https://api.opensuse.org/source/devel:languages:perl/_meta
Building perl-Test-Base.spec for SLE_11/x86_64
Getting buildinfo from server
POST
https://api.opensuse.org/build/devel:languages:perl/SLE_11/x86_64/perl-Test-Base/_buildinfo?add=tree&add=vim
buildinfo is broken... it says:
expansion error: nothing provides perl(Test::Deep)

As you can see there is no "Evaluating preferred packages"
This behavior exists only if there is no build binary for needed pkg on obs.

Yes currently the obs has no support for this - some time ago I wrote a small
patch for it but I don't know if that's the right way to implement it:)
(see http://lists.opensuse.org/opensuse-buildservice/2009-03/msg00002.html).


Marcus

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
References