Mailinglist Archive: opensuse-buildservice (213 mails)

< Previous Next >
Re: [opensuse-buildservice] osc: svn trunk currently borked for old python revisions
  • From: Peter Poeml <poeml@xxxxxxx>
  • Date: Tue, 16 Jun 2009 14:17:44 +0200
  • Message-id: <20090616121744.GA10989@xxxxxxx>
Hi,

On Fri, Jun 12, 2009 at 04:21:57PM +0200, Martin Mohring wrote:
it happened again that checkins of osc source code did not take care of
the fact that osc is not only running on python 2.5 or 2.6 based
systems. please be aware that osc currently oldest python versions are
in debian 4.0, SLE 10, RHEL 5.

Error:

+ CFLAGS='-O2 -g'
+ /usr/bin/python setup.py build
Traceback (most recent call last):
File "setup.py", line 7, in ?
import osc.core
File "/usr/src/redhat/BUILD/osc-svn-0.119.7523S/osc/core.py", line 898
finally:
^
SyntaxError: invalid syntax
error: Bad exit status from /var/tmp/rpm-tmp.68761 (%build)

At least Debian 4.0, RHEL 5, SLE 10, CentOS 5 etc. are affected.

Introduced by me with r7507. Should be fixed with r7531.

Thanks,
Peter
--
"WARNING: This bug is visible to non-employees. Please be respectful!"

SUSE LINUX Products GmbH
Research & Development
< Previous Next >
References