Mailinglist Archive: opensuse-buildservice (239 mails)

< Previous Next >
[opensuse-buildservice] How to resolve build errors with liked packages
  • From: Richard Bos <rbos@xxxxxxxxxxxx>
  • Date: Mon, 4 May 2009 12:55:39 +0200
  • Message-id: <200905041255.40065.rbos@xxxxxxxxxxxx>
Hi,

I get the following message:
devel:languages:perl/perl-ldap> osc up
Link cannot be expanded:
could not apply patch 'project.diff'
Use "osc repairlink" to fix merge conflicts.

when working on the package perl-ldap in the repository devel:languages:perl.
So I do:

Which result in:
devel:languages:perl/perl-ldap> osc repairlink
using last working link target
G perl-ldap-0.39.tar.bz2
U perl-ldap.changes
C perl-ldap.spec
ready

Please change into the 'repairlink' directory,
fix the conflicts, and commit the changes.

I fix the conflicting perl-ldap.spec file. At least that is what I think, and
execute:
devel:languages:perl/perl-ldap/repairlink> osc ci -m "repair broken linkage
(with Factory)" perl-ldap.spec
Please resolve all conflicts before committing!

I did clearly something wrong, but what? I just want to update to the latest
version. As such I removed the lines that are no longer needed from the file:
repairlink/perl-ldap.spec (e.g. I removed version: 0.37 in favour of the new
line containing version: 0.39).

The package contains the files:
devel:languages:perl/perl-ldap> osc ls devel:languages:perl perl-ldap
_link
perl-ldap-0.39.tar.bz2
project.diff
project1.diff

I no longer need the project.diff files (1 change I can easily create again).
What is correct way to deal with this???

--
Richard

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups