Mailinglist Archive: opensuse-buildservice (239 mails)

< Previous Next >
Re: [opensuse-buildservice] recent 1.6beta2 obs-worker and src-server won't start
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Mon, 4 May 2009 08:56:40 +0200
  • Message-id: <200905040856.40810.adrian@xxxxxxx>
Am Freitag, 1. Mai 2009 20:49:34 schrieb Jon Nelson:
Previously I was running obs 1.6beta2 release 1.1

Do you have upgraded the build.rpm as well ?
Build perl module files get used from this package now.

What does "rpm -V obs-server build" say ?

The upgrade exchanges a directory with a sym link, maybe the %pre script does
not work correctly ...

bye
adrian


For obsworker:


Run 2 obsworker using /tmp/build
/var/run/obs/worker/boot ~

curl: (7) couldn't connect to host
cpio: premature end of archive
chmod: cannot access `bs_worker': No such file or directory
~
/var/run/obs/worker/boot ~
~




For src-server:

Initializing obssrcserverCan't locate Build.pm in @INC (@INC contains:
/usr/lib/obs/server/ /usr/lib/obs/server//build
/usr/lib/perl5/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/5.10.0
/usr/lib/perl5/site_perl/5.10.0/x86_64-linux-thread-multi
/usr/lib/perl5/site_perl/5.10.0
/usr/lib/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl .) at
/usr/lib/obs/server//bs_srcserver line 50.
BEGIN failed--compilation aborted at /usr/lib/obs/server//bs_srcserver line
50.




The version of the 'build' package went from 2009.03.23-39.1 to
2009.04.23-46.1 at the same time.

--

Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References