Mailinglist Archive: opensuse-buildservice (250 mails)

< Previous Next >
Re: [opensuse-buildservice] BuildRequires: libmysqlclient-devel on Fedora?
  • From: Michal Čihař <michal@xxxxxxxxx>
  • Date: Mon, 6 Apr 2009 15:49:04 +0200
  • Message-id: <20090406154904.52726d57@xxxxxxxxxxxxxxxxx>
Hi

Dne Mon, 6 Apr 2009 09:46:03 -0400
Greg Freemyer <greg.freemyer@xxxxxxxxx> napsal(a):

My simple open2300 project is now building for OpenSUSE.

Couple questions:

1) I have a "BuildRequires: libmysqlclient-devel" directive in the
spec file.

If I try to add the fedora repository, it tells me that package does
not exist. All I need is the mysql.h file.

Fedora has mysql-devel.

Is there a set of cross references that tell what package I need for fedora?

Is there a more distro neutral way to say I need the package that
provides mysql.h?

If not, how do I have different BuildRequires statements for different
distros?

I ended up with evil set of if statements:
http://viewsvn.cihar.com/viewvc.cgi/gammu/trunk/gammu.spec?view=markup

--
Michal Čihař | http://cihar.com | http://blog.cihar.com
< Previous Next >
References