Mailinglist Archive: opensuse-buildservice (250 mails)

< Previous Next >
Re: [opensuse-buildservice] problem with obs_mirror_project -solved-
  • From: Christian <chris@xxxxxxxxxxxxxxxx>
  • Date: Thu, 02 Apr 2009 22:44:52 +0000
  • Message-id: <49D53FE4.3040906@xxxxxxxxxxxxxxxx>
Hi,

osc http_debug was enabled :)

Christian schrieb:
Hi,

is it normal, that all rpms that are loaded via obs_mirror_project have

-- GET
https://api.opensuse.org/build/openSUSE:11.1/standard/i586/_repository/3ddiag.rpm
send: 'GET /build/openSUSE:11.1/standard/i586/_repository/3ddiag.rpm
HTTP/1.1\r\nAccept-Encoding: identity\r\nHost:
api.opensuse.org\r\nCookie: IPCZQX018ef15359=0000c10179698f6c49648fcb;
ZNPCQ002-api=V001d93b35d9\r\nConnection: close\r\nUser-agent: o
sc/0.115\r\n\r\n'
reply: 'HTTP/1.1 200 OK\r\n'
header: X-Opensuse-Apiversion: 0.1.2
header: X-Runtime: 2.89403
header: Cache-Control: no-cache
header: Content-Disposition: attachment; filename="3ddiag.rpm"
header: Date: Thu, 02 Apr 2009 16:00:08 GMT
header: Server: lighttpd/1.5.0
header: Content-Type: application/x-rpm; charset=utf-8
header: Connection: close
header: Content-Length: 18422
header: Via: 1.1 ICS_SERVER (iChain 2.3.410)


at the beginning of the file if you do 'less 3ddiag.rpm'

same with project files
- openSUSE:11.1.conf


-- GET https://api.opensuse.org/source/openSUSE:11.1/_config
send: 'GET /source/openSUSE:11.1/_config HTTP/1.1\r\nAccept-Encoding:
identity\r\nHost: api.opensuse.org\r\nCookie:
IPCZQX018ef15359=0000c10179698f6c49648fcb;
ZNPCQ002-api=V001d93b35d9\r\nConnection: close\r\nUser-agent:
osc/0.115\r\n\r\n'
reply: 'HTTP/1.1 200 OK\r\n'
header: X-Opensuse-Apiversion: 0.1.2^M
header: X-Runtime: 0.02820^M
header: ETag: "8fed55703f014d82dbd8dbebd115c7a5"^M
header: Content-Transfer-Encoding: binary^M
header: Cache-Control: private^M
header: Content-Disposition: inline^M
header: Date: Thu, 02 Apr 2009 15:59:51 GMT^M
header: Server: lighttpd/1.5.0^M
header: Content-Type: text/plain^M
header: Connection: close^M
header: Content-Length: 21920^M
header: Via: 1.1 ICS_SERVER (iChain 2.3.410)^M

- openSUSE:11.1.xml


-- GET https://api.opensuse.org/source/openSUSE:11.1/_meta
send: 'GET /source/openSUSE:11.1/_meta HTTP/1.1\r\nAccept-Encoding:
identity\r\nHost: api.opensuse.org\r\nCookie:
IPCZQX018ef15359=0000c10179698f6c49648fcb;
ZNPCQ002-api=V001d93b35d9\r\nConnection: close\r\nUser-agent:
osc/0.115\r\n\r\n'
reply: 'HTTP/1.1 200 OK\r\n'
header: X-Opensuse-Apiversion: 0.1.2^M
header: X-Runtime: 0.00422^M
header: ETag: "8a4bc88203fc61d0805933e61798d0ff"^M
header: Cache-Control: private, max-age=0, must-revalidate^M
header: Date: Thu, 02 Apr 2009 15:59:50 GMT^M
header: Server: lighttpd/1.5.0^M
header: Content-Type: text/xml; charset=utf-8^M
header: Connection: close^M
header: Content-Length: 1037^M
header: Via: 1.1 ICS_SERVER (iChain 2.3.410)^M

it doesn't make any difference if I use with/without '-v'
Kind Regards
Chris

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
This Thread
References