Mailinglist Archive: opensuse-buildservice (206 mails)

< Previous Next >
Re: [opensuse-buildservice] problems with OBS 1.5rc2 after upgrading host to openSUSE 11.1
  • From: Jon Nelson <jnelson-suse@xxxxxxxxxxx>
  • Date: Fri, 13 Mar 2009 19:24:04 -0500
  • Message-id: <cccedfc60903131724t7c31a4a6h2bed6f77aef8b5af@xxxxxxxxxxxxxx>
On Fri, Mar 13, 2009 at 2:31 PM, Jon Nelson <jnelson-suse@xxxxxxxxxxx> wrote:
On Fri, Mar 13, 2009 at 2:17 PM, Andreas Bauer <abauer@xxxxxxx> wrote:
Jon Nelson schrieb:
I had a number of problems after upgrading an OBS instance from
openSUSE 11.0 to 11.1
The client remains running openSUSE 11.1, as it has for months. The
osc version on the client has not changed and is the latest available.


The first is that adding a *comment* via osc did not work.
I could add and remove files (PUT/DELETE respectively), but the
subsequent POST would not, returning a 403.

I have no idea why this is, but the *logfile* permissions were wrong.
Why that resulted in a 403 (despite the action being successful) is
beyond me, but the logfiles were owned by root.root.
When I fixed that, my problems went away.


The second problem still stands:

Second problem: only for the 'Admin' user, editing the user info
(/user/edit) fails every time with:

undefined method `source_backend' for #<Person:0x7fac0a31a048>

What might be going on here?

Are you trying to edit using the admin interface of the frontend or
the user edit page of the webclient?

The web interface. Log in as Admin. Go to 'home'. Edit user info. Boom. :-(


and I found a third one!

Restarting obsworker results in a second screen session, and a third,
and a fourth, and so on.
obsworker's init script should kill the screen session that it starts.


--
Jon
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups