Mailinglist Archive: opensuse-buildservice (273 mails)

< Previous Next >
[opensuse-buildservice] Status latency in build.opensuse.org
  • From: Lars Marowsky-Bree <lmb@xxxxxxx>
  • Date: Fri, 30 Jan 2009 18:22:57 +0100
  • Message-id: <20090130172257.GI26058@xxxxxxx>
Hi,

what's the reason for the latency in status displays on b.o.o?

When I enable building for a previously disabled arch, it took several
minutes to update the status from "disabled" to building/blocked.

I understand that this is partly due to the scheduler re-run needed, but
because that time is not known or exposed, one looks through all the
expert settings to figure out what one has done wrong, or if there isn't
a flag one overlooked.

Sometimes the same happens between "finished" to "succeeded", or when
the build has finished when the buid log seems to switch from "live" to
"archived", there's a gap there the build has finished (possibly failed)
but the log then still shows the outdated one - which build fine or
aborted with a different error.

It's a usability nightmare.

Can't we at least - if the latencies can't be reduced for some reason -
immediately wipe the outdated state? I'd rather see a "Please wait"
message until the next scheduler run instead of wrong information.


Regards,
Lars

--
Teamlead Kernel, SuSE Labs, Research and Development
SUSE LINUX Products GmbH, GF: Markus Rex, HRB 16746 (AG N├╝rnberg)
"Experience is the name everyone gives to their mistakes." -- Oscar Wilde

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages