Mailinglist Archive: opensuse-buildservice (273 mails)

< Previous Next >
Re: [opensuse-buildservice] How to use %debug_package
  • From: Cristian Morales Vega <cmorve69@xxxxxxxx>
  • Date: Tue, 27 Jan 2009 06:28:55 +0100
  • Message-id: <8235e6f40901262128x719fcba0i3262bb3f9a494704@xxxxxxxxxxxxxx>
2009/1/26 Matthias Bach <marix@xxxxxxxxx>:
Hi!

Trying to be prepare some packages for contrib I stumbeled upon the problem of
stripping the package of its debug information. Now I learned that install-
strip is not the way to go, as it will make it impossible to debug the
application, and I should use %debug_packges, as that will create a "-debug"
package with the stripped information.

Having added a line "%debug_package" to the spec-file now gives me a strip
package without using install-strip. It won't give me a "-debug"-package so,
caused by the following problem printed by osc-out.

Preparing packages for installation...
vorbisgain-debuginfo-0.34-8
vorbisgain-debugsource-0.34-8
vorbisgain-0.34-8
... running 01-check-debuginfo
... testing for empty debuginfo packages
!
! vorbisgain-debugsource-0.34-8.x86_64.rpm: no debug sources, deleting
package
! vorbisgain-debuginfo-0.34-8.x86_64.rpm: WARNING: this probably means the
debug information is invalid
!

Compare "osc meta prj home:TheMarix" and "osc meta prj
openSUSE:Factory:Contrib" outputs.
Contrib has a:
<debuginfo>
<enable/>
</debuginfo>

After adding it the BS will add %debug_package automatically to your
package. If you add %debug_package yourself the package will fail to
build in Contrib because of a duplicate -debug* package (or that was
the behavior last time I checked).

Then I think you need to add "-g" to the build flags. The vorbisgain
makefile doesn't seems to add it and I'm not sure if the BS will add
it automatically when you add <debuginfo> (if doesn't, probably it should?).
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
References