Mailinglist Archive: opensuse-buildservice (273 mails)

< Previous Next >
[opensuse-buildservice] Error satisfying "BuildRequires" for non SuSE distro's
  • From: Joop Boonen <joop_boonen@xxxxxx>
  • Date: Sat, 24 Jan 2009 23:44:07 +0100
  • Message-id: <497B99B7.9040601@xxxxxx>
|All,

I get a build error for all non SuSE distro's on "BuildRequires". I've
checked the names in a test installation they are correct if I'm not
mistaken.

This are the "BuildRequires" in the spec file:

<quote>
%if 0%{?suse_version}
BuildRequires: libusb-devel, pkg-config, subversion >= 1.5.0
%elseif
BuildRequires: libusb-devel, pkgconfig, subversion >= 1.5.0
%endif
</quote>

This is the build error I get:

<quote>
I have the following modifications for dfu-util.spec:
17c17
< Release: 5.2
---
Release: 5.1
-----------------------------------------------------------------
----- building dfu-util.spec (user abuild)
-----------------------------------------------------------------
-----------------------------------------------------------------
+ exec rpmbuild -ba --define '_srcdefattr (-,root,root)' --define
'disturl srcrep:1d4ecab9cbd0e3b0f54c29caf9af5778-dfu-util'
/home/abuild/rpmbuild/SOURCES/dfu-util.spec
error: Failed build dependencies:
libusb-devel is needed by dfu-util-0.1+svn4900-5.1.src
pkgconfig is needed by dfu-util-0.1+svn4900-5.1.src
subversion >= 1.5.0 is needed by dfu-util-0.1+svn4900-5.1.src
System halted.
</quote>

Regards,

Joop.
|
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >