Mailinglist Archive: opensuse-buildservice (233 mails)

< Previous Next >
Re: [opensuse-buildservice] osc build against local obs instance, remoteurl'ed repos
  • From: Martin Mohring <martin.mohring@xxxxxxxxxxxx>
  • Date: Wed, 17 Dec 2008 14:32:26 +0100
  • Message-id: <4948FF6A.6050609@xxxxxxxxxxxx>
Jan-Simon Möller wrote:
Am Mittwoch, 17. Dezember 2008 14:10:43 schrieb Dominique Leuenberger:

Hi everybody...

This might be a tricky one, and I hope I'll be able to explain what I try
to do and what fails. Maybe it's a mistake from my side (can't be ruled
out), maybe a missing feature, maybe a bug. The goal is to figure this out
and in the last two cases create a bugreport and in the first case train
the error between chair and keyboard (me).

Situation:
- Local install of OBS (upgraded to 1.5rc1 as of this morning).
- One Project in my OBS (projectX)
- projectX has this in the prj meta data:
<repository name="11.1">
<path repository="standard" project="openSUSE.org:openSUSE:11.1"/>
<arch>i586</arch>
<arch>x86_64</arch>
</repository>

openSUSE.org is, supposedly, remoteurl'ing build.o.o (you guessed that).

Building packages like this works fine (and rocks!) if I check them in and
let BS deal with it. BUT:
if I use
#> losc co proxectX packageY
(losc is an alias on my system to osc -A http://127.0.42.2)
and then
#> osc build 11.1 i586 packageX.spec
I get the following error:
Building packageX.spec for 11.1/i586
Getting buildinfo from server
BuildService API error: buildinfo for package aaa_base/i586/None is
incomplete

So there seems still to be something missing :(

That is a known issue. Version info is not present for remoteurl.
That was why we (Marcus Hüwe and me) implemented Download on Demand for
OBS 1.5

Martin

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >