Mailinglist Archive: opensuse-buildservice (266 mails)

< Previous Next >
[opensuse-buildservice] problems with latest obs packages
  • From: "Jon Nelson" <jnelson@xxxxxxxxxxx>
  • Date: Fri, 7 Nov 2008 13:59:50 -0600
  • Message-id: <cccedfc60811071159x7558be5ale5b8f93602d5d021@xxxxxxxxxxxxxx>
I just finished upgrading obs-worker, obs-server, and obs-api to
1.0.0-6.1 on my opensuse 11.0 box.

Unfortunately, the update appears to have broken the web front end.

I had to strace the lighttpd process to figure out *part* of the problem:

3044 write(2, "Missing the Rails 1.2.6 gem. Please `gem install
-v=1.2.6 rails`, update your RAILS_GEM_VERSION setting in
config/environment.rb for the Rails version you do have installed, or
comment out RAILS_GEM_VERSION to use the latest version installed.",
243) = 243

I corrected this by *COMMENTING OUT*

RAILS_GEM_VERSION = "1.2.6"

in /srv/www/obs/webclient/config/environment.rb

The error logs from the ruby processes are going to /dev/null - they
probably ought to go somewhere useful.

Lastly, I now get this error:

On line #23 of package/_files.rhtml

20: <%= link_to("[Show]", :action => :view_file, :project
=> @project,
21: :package => @package, :file => file[:name] ) %>
22: </td>
23: <td><%= link_to "[Download]", file_url( @project,
@package, file[:name] ) %></td>
24: <td><%= link_to "[Remove]", {:action => :remove_file,
:project => @project,
25: :package => @package, :filename => file[:name]},
26: {:confirm => "Really remove file '#{file[:name]}'?" }%></td>

app/helpers/application_helper.rb:58:in `const_defined?'
app/helpers/application_helper.rb:58:in `get_frontend_url_for'
app/helpers/package_helper.rb:9:in `file_url'
app/views/package/_files.rhtml:23:in
`_run_erb_47app47views47package47_files46rhtml'
app/views/package/_files.rhtml:11:in `each'
app/views/package/_files.rhtml:11:in
`_run_erb_47app47views47package47_files46rhtml'
/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/base.rb:637:in
`send'
/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/base.rb:637:in
`compile_and_render_template'
/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/base.rb:365:in
`render_template'
/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/base.rb:316:in
`render_file'
/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/base.rb:331:in
`render'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/partials.rb:120:in
`render_partial'
/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/base.rb:352:in
`render'
app/views/package/show.rhtml:39:in
`_run_erb_47app47views47package47show46rhtml'
/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/base.rb:637:in
`send'
/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/base.rb:637:in
`compile_and_render_template'
/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/base.rb:365:in
`render_template'
/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/base.rb:316:in
`render_file'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:1100:in
`render_for_file'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:836:in
`render_with_no_layout'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/layout.rb:262:in
`render_without_benchmark'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/benchmarking.rb:51:in
`render'
/usr/lib64/ruby/1.8/benchmark.rb:293:in `measure'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/benchmarking.rb:51:in
`render'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:1153:in
`default_render'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:1159:in
`perform_action_without_filters'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/filters.rb:697:in
`call_filters'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/filters.rb:689:in
`perform_action_without_benchmark'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/benchmarking.rb:68:in
`perform_action_without_rescue'
/usr/lib64/ruby/1.8/benchmark.rb:293:in `measure'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/benchmarking.rb:68:in
`perform_action_without_rescue'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/rescue.rb:199:in
`perform_action'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:524:in
`send'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:524:in
`process_without_filters'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/filters.rb:685:in
`process_without_session_management_support'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/session_management.rb:123:in
`process'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:388:in
`process'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/dispatcher.rb:171:in
`handle_request'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/dispatcher.rb:115:in
`dispatch'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/dispatcher.rb:126:in
`dispatch_cgi'

/usr/lib64/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/dispatcher.rb:9:in
`dispatch'
/usr/lib64/ruby/gems/1.8/gems/rails-2.0.2/lib/fcgi_handler.rb:101:in
`process_request'
/usr/lib64/ruby/gems/1.8/gems/rails-2.0.2/lib/fcgi_handler.rb:149:in
`with_signal_handler'
/usr/lib64/ruby/gems/1.8/gems/rails-2.0.2/lib/fcgi_handler.rb:99:in
`process_request'
/usr/lib64/ruby/gems/1.8/gems/rails-2.0.2/lib/fcgi_handler.rb:77:in
`process_each_request'
/usr/lib64/ruby/vendor_ruby/1.8/fcgi.rb:612:in `each_cgi'
/usr/lib64/ruby/vendor_ruby/1.8/fcgi.rb:609:in `each'
/usr/lib64/ruby/vendor_ruby/1.8/fcgi.rb:609:in `each_cgi'
/usr/lib64/ruby/gems/1.8/gems/rails-2.0.2/lib/fcgi_handler.rb:76:in
`process_each_request'
/usr/lib64/ruby/gems/1.8/gems/rails-2.0.2/lib/fcgi_handler.rb:50:in
`process!'
/usr/lib64/ruby/gems/1.8/gems/rails-2.0.2/lib/fcgi_handler.rb:24:in
`process!'
public/dispatch.fcgi:24

when trying to view a package.

I just removed line 23 for now to get it working.

--
Jon
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages