Mailinglist Archive: opensuse-buildservice (184 mails)

< Previous Next >
Re: [opensuse-buildservice] Problems recompiling dspam 3.8.0-40.1
  • From: Boyd Lynn Gerber <gerberb@xxxxxxxxx>
  • Date: Mon, 6 Oct 2008 08:48:53 -0600
  • Message-id: <alpine.LNX.1.10.0810060831290.5083@xxxxxxxxxxxxxxxxx>
On Mon, 6 Oct 2008, Claudio Prono wrote:
I have to recompile dspam to add a feature (*--enable-domain-scale), *so
i have get the src of DSPAM for SUSE from here:

http://download.opensuse.org/repositories/server:/mail/openSUSE_11.0/src/dspam-3.8.0-40.1.src.rpm

Then, i have tried at first to recompile from source, with that command:

rpmbuild --rebuild dspam-3.8.0-40.1.src.rpm

But it's fails, here is the complete log:

Installing dspam-3.8.0-40.1.src.rpm
warning: InstallSourcePackage: Header V3 DSA signature: NOKEY, key ID
367fe7fc
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.72445
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd /usr/src/packages/BUILD
+ rm -rf dspam-3.8.0
...
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd dspam-3.8.0
...

The errors below are errors from the auto-tools build. autoconf, libtool,... You have to have them installed and useable. I would try to use a local instance of them and try build with osc

osc co server:mail dspam
cd ~/dspam
osc build openSUSE_11.0 x86_64 dspam.spec

or
osc build openSUSE_11.0 i586 dspam.spec

This will make sure you have everything you need. Because below looks like issues with your auto-build utils.

+ autoreconf -fi
configure.ac:705: warning: AC_PROG_LIBTOOL is m4_require'd but not
m4_defun'd
m4/libtool_hack.m4:19: DS_LIBTOOL_RUN_IFELSE is expanded from...
m4/sqlite_drv.m4:154: DS_SQLITE_LIBS is expanded from...
m4/sqlite_drv.m4:308: DS_SQLITE is expanded from...
configure.ac:705: the top level
configure.ac:729: warning: AC_PROG_LIBTOOL is m4_require'd but not
m4_defun'd
m4/sqlite3_drv.m4:154: DS_SQLITE3_LIBS is expanded from...
m4/sqlite3_drv.m4:308: DS_SQLITE3 is expanded from...
configure.ac:729: the top level
configure.ac:705: warning: AC_PROG_LIBTOOL is m4_require'd but not
m4_defun'd
m4/libtool_hack.m4:19: DS_LIBTOOL_RUN_IFELSE is expanded from...
m4/sqlite_drv.m4:154: DS_SQLITE_LIBS is expanded from...
m4/sqlite_drv.m4:308: DS_SQLITE is expanded from...
configure.ac:705: the top level
configure.ac:729: warning: AC_PROG_LIBTOOL is m4_require'd but not
m4_defun'd
m4/sqlite3_drv.m4:154: DS_SQLITE3_LIBS is expanded from...
m4/sqlite3_drv.m4:308: DS_SQLITE3 is expanded from...
configure.ac:729: the top level
configure.ac:705: warning: AC_PROG_LIBTOOL is m4_require'd but not
m4_defun'd
m4/libtool_hack.m4:19: DS_LIBTOOL_RUN_IFELSE is expanded from...
m4/sqlite_drv.m4:154: DS_SQLITE_LIBS is expanded from...
m4/sqlite_drv.m4:308: DS_SQLITE is expanded from...
configure.ac:705: the top level
configure.ac:729: warning: AC_PROG_LIBTOOL is m4_require'd but not
m4_defun'd
m4/sqlite3_drv.m4:154: DS_SQLITE3_LIBS is expanded from...
m4/sqlite3_drv.m4:308: DS_SQLITE3 is expanded from...
configure.ac:729: the top level
configure.ac:24: error: possibly undefined macro: AC_PROG_LIBTOOL
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1
error: Bad exit status from /var/tmp/rpm-tmp.16117 (%build)


RPM build errors:
InstallSourcePackage: Header V3 DSA signature: NOKEY, key ID 367fe7fc
Bad exit status from /var/tmp/rpm-tmp.16117 (%build)

What is the problem? I need this to migrate a old DSPAM with the
function "*--enable-domain-scale" *active, without this i can't copy old
logs and stats from the older installation... help me pls.

See above. These errors are from the auto-build utils.

--
Boyd Gerber <gerberb@xxxxxxxxx>
ZENEZ 1042 East Fort Union #135, Midvale Utah 84047
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References