Mailinglist Archive: opensuse-buildservice (249 mails)

< Previous Next >
[opensuse-buildservice] Problem pulling repos
  • From: "Andrés G. Aragoneses" <knocte@xxxxxxxxx>
  • Date: Sat, 30 Aug 2008 18:17:05 +0200
  • Message-id: <g9brqe$4ov$1@xxxxxxxxxxxxx>
Hello,

I'm packaging my first app in OBS. It's noarch and firstly focused on OpenSUSE 11.0. It depends on some packages I've found that are available in this repo:

http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_11.0/

So then I've included it in the metadata of mine, using:

osc meta prj -e home:knocte:bugzilla

My XML ends up being:

<project name="home:knocte:bugzilla">
<title>OBS packages for bugzilla server software</title>
<description></description>
<person role="maintainer" userid="knocte"/>
<person role="bugowner" userid="knocte"/>
<repository name="openSUSE_11.0">
<path repository="standard" project="openSUSE:11.0"/>
<path repository="openSUSE_11.0" project="devel:languages:perl"/>
<arch>i586</arch>
<arch>x86_64</arch>
</repository>
</project>


Now it seems that there is a problem on the resolution of dependencies because I'm only able to install the packages apparently by 1 of 4 ways I've tried:

1) 1-click install from software.opensuse.org: I get wierd problems about not being able to contact with the repository.

2) Adding my home repository to Yast->Software repositories, and trying to install it from Yast->Software Management: I get a segmentation fault.

3) Adding my home repository to Yast->Software repositories, and trying to install the package with zypper ("sudo zypper install bugzilla"):

> sudo zypper install bugzilla
root's password:
Reading installed packages...

Problem: nothing provides perl-Email-MIME >= 1.816 needed by bugzilla-3.2rc1-19.1.noarch
Solution 1: do not ask to install a solvable providing bugzilla

Choose the above solution using '1' or cancel using 'c' [1/C]:

4) Adding my home repository *and* the devel:languages:perl repository to Yast->Software repositories, and install it from Yast->Software Management: it works!


What should I do to get the package working with all ways and not only the last one? Thanks in advance.

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >