Mailinglist Archive: opensuse-buildservice (351 mails)

< Previous Next >
Re: [opensuse-buildservice] Problem with build for 11.0
  • From: "Dr. Axel Braun" <axel.braun@xxxxxx>
  • Date: Fri, 11 Jul 2008 20:14:31 +0200
  • Message-id: <200807112014.31708.axel.braun@xxxxxx>
Hi,

Am Freitag, 11. Juli 2008 schrieb Adrian Schröter:

In the .spec for the project this libstdc++ is included:

BuildRequires: libjpeg-devel, libtiff-devel, zlib-devel, gcc, gcc-c++,
libstdc++

libstdc++-devel is missing ?

acctually, you do not not need gcc, gcc-c++ and libstdc++ in BuildRequires,
if you require that.

I put the devel package in, but the error remains the same. I attach the build
log....

Thanks
Axel


--
Dr.-Ing. Axel K. Braun
M: +49.(0)173.7003.154
VoIP/Skype: axxite
PGP Fingerprint: CB03 964D 1CFA E87B AA63 53F3 1BD6 F53A EB48 EF22
Public Key available at http://www.axxite.com/axel.braun@xxxxxxxxxx

This mail was *not scanned* before sending.
It was sended from a virus-free Linux desktop.

Using BUILD_ROOT=/abuild/root_3/.mount
Using BUILD_ARCH=i586:i486:i386
Doing XEN build in /dev/abuild/3_root


build14 started "build hylafax433.spec" at Fri Jul 11 15:22:35 UTC 2008.

Building hylafax433 for project 'home:DocB' repository 'openSUSE_11.0' arch
'i586' srcmd5 '6b9c1c1a3b215a88ac5c5218a4315fc9

processing specfile /abuild/root_3/.build-srcdir/hylafax433.spec...
running changelog2spec --target rpm --file
/abuild/root_3/.build-srcdir/hylafax433.spec
init_buildsystem --prepare --clean --rpmlist /abuild/root_3/.rpmlist
/abuild/root_3/.build-srcdir/hylafax433.spec build rpmlint-mini ...
preinstalling aaa_base...
preinstalling acl...
preinstalling attr...
preinstalling bash...
preinstalling coreutils...
preinstalling diffutils...
preinstalling filesystem...
preinstalling fillup...
preinstalling glibc...
preinstalling grep...
preinstalling insserv...
preinstalling libacl...
preinstalling libattr...
preinstalling libbz2-1...
preinstalling libgcc43...
preinstalling libxcrypt...
preinstalling m4...
preinstalling libncurses5...
preinstalling pam...
preinstalling permissions...
preinstalling popt...
preinstalling libreadline5...
preinstalling rpm...
preinstalling sed...
preinstalling tar...
preinstalling zlib...
preinstalling util-linux...
preinstalling perl-base...
preinstalling libdb-4_5...
preinstalling libvolume_id...
copying packages...
reordering...done
booting XEN kernel ...
perl -e syscall(135, 0); exec(@ARGV) || die("$ARGV[0]: $!\n") xm create -c
/var/run/bsworker_3/build/xen.conf name=build:3_root memory=750
disk=phy:/dev/abuild/3_root,hda1,w disk=phy:/dev/abuild/3_swap,hda2,w
extra=init=/.build/build panic=1 console=ttyS0
Using config file "/var/run/bsworker_3/build/xen.conf".
Started domain build:3_root
Bootdata ok (command line is root=/dev/hda1 ro init=/.build/build panic=1
console=ttyS0)
Linux version 2.6.16.60-0.24-xen (geeko@buildhost) (gcc version 4.1.2 20070115
(SUSE Linux)) #1 SMP Fri Jun 20 11:22:09 UTC 2008
BIOS-provided physical RAM map:
Xen: 0000000000000000 - 000000002f600000 (usable)
No mptable found.
Built 1 zonelists
Kernel command line: root=/dev/hda1 ro init=/.build/build panic=1 console=ttyS0
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 131072 bytes)
Xen reported: 2210.184 MHz processor.
Console: colour dummy device 80x25
Dentry cache hash table entries: 131072 (order: 8, 1048576 bytes)
Inode-cache hash table entries: 65536 (order: 7, 524288 bytes)
Software IO TLB disabled
Memory: 741660k/776192k available (1961k kernel code, 26148k reserved, 825k
data, 164k init)
Calibrating delay using timer specific routine.. 4422.18 BogoMIPS (lpj=8844375)
Security Framework v1.0.0 initialized
Mount-cache hash table entries: 256
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 1024K (64 bytes/line)
checking if image is initramfs... it is
Freeing initrd memory: 6920k freed
Brought up 1 CPUs
migration_cost=0
NET: Registered protocol family 16
Brought up 1 CPUs
PCI: setting up Xen PCI frontend stub
ACPI: Subsystem revision 20060127
ACPI: Interpreter disabled.
xen_mem: Initialising balloon driver.
PCI: System does not support PCI
PCI: System does not support PCI
Setting mem allocation to 768000 kiB
IA32 emulation $Id: sys_ia32.c,v 1.32 2002/03/24 13:02:28 ak Exp $
audit: initializing netlink socket (disabled)
audit(1215789767.430:1): initialized
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
rtc: IRQ 8 is not free.
Non-volatile memory driver v1.2
i8042.c: No controller found.
RAMDISK driver initialized: 16 RAM disks of 128000K size 1024 blocksize
Xen virtual console successfully installed as xvc0
Event-channel device installed.
mice: PS/2 mouse device common for all mice
input: PC Speaker as /class/input/input0
md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 4.39
NET: Registered protocol family 2
IP route cache hash table entries: 32768 (order: 6, 262144 bytes)
TCP established hash table entries: 131072 (order: 9, 2097152 bytes)
TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
NET: Registered protocol family 1
XENBUS: Device with no driver: device/vbd/769
XENBUS: Device with no driver: device/vbd/770
XENBUS: Device with no driver: device/console/0
Freeing unused kernel memory: 164k freed
Starting udevd
Creating devices
Loading ide-core
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 50MHz system bus speed for PIO modes; override with idebus=xx
Loading ide-disk
Loading scsi_mod
SCSI subsystem initialized
Loading sd_mod
Loading amd74xx
Loading aacraid
Adaptec aacraid driver 1.1-5[2449]-suse
Loading xennet
netfront: Initialising virtual ethernet driver.
Loading xenblk
xen-vbd: registered block device major 3
blkfront: hda1: barriers enabled
blkfront: hda2: barriers enabled
Loading reiserfs
Loading jbd
Loading ext3
Waiting for device /dev/hda1 to appear: ok
rootfs: major=3 minor=1 devn=769
Mounting root /dev/hda1
XEN 2nd stage started
machine type: x86_64
switching personality to 134217736...
XEN 2nd stage started
machine type: i686
swapon on /dev/hda2
Adding 1535992k swap on /dev/hda2. Priority:-1 extents:1 across:1535992k
mount: none already mounted or //proc busy
logging output to //.build.log...
Using BUILD_ROOT=/
Using BUILD_RPMS=/media/dvd/suse
Using BUILD_ARCH=i586:i486:i386


build14 started "build hylafax433.spec" at Fri Jul 11 15:22:50 UTC 2008.

Building hylafax433 for project 'home:DocB' repository 'openSUSE_11.0' arch
'i586' srcmd5 '6b9c1c1a3b215a88ac5c5218a4315fc9

processing specfile /.build-srcdir/hylafax433.spec...
init_buildsystem /.build-srcdir/hylafax433.spec build rpmlint-mini ...
running aaa_base preinstall script
running aaa_base postinstall script
Updating etc/sysconfig/language...
Updating etc/sysconfig/backup...
Updating etc/sysconfig/boot...
Updating etc/sysconfig/kernel...
Updating etc/sysconfig/suseconfig...
Updating etc/sysconfig/clock...
Updating etc/sysconfig/proxy...
Updating etc/sysconfig/windowmanager...
Updating etc/sysconfig/sysctl...
Updating etc/sysconfig/cron...
Updating etc/sysconfig/news...
Updating etc/sysconfig/shutdown...
Updating etc/passwd...unchanged
Updating etc/group...unchanged
Updating etc/shadow...new
initializing rpm db...
installing filesystem-11.0-42.1
installing terminfo-base-5.6-83.1
installing glibc-2.8-14.1
warning: /etc/bindresvport.blacklist created as
/etc/bindresvport.blacklist.rpmnew
warning: /etc/default/nss created as /etc/default/nss.rpmnew
warning: /etc/gai.conf created as /etc/gai.conf.rpmnew
warning: /etc/nsswitch.conf created as /etc/nsswitch.conf.rpmnew
warning: /etc/rpc created as /etc/rpc.rpmnew
installing audit-libs-1.6.8-18.1
installing fillup-1.42-216.1
installing gdbm-1.8.3-344.1
installing glibc-locale-2.8-14.1
installing libattr-2.4.39-40.1
installing libbz2-1-1.0.5-13.1
installing libdb-4_5-4.5.20-67.1
installing libjpeg-6.2.0-852.1
installing libltdl-3-1.5.26-23.1
installing libvolume_id-120-13.1
installing libxcrypt-3.0-14.1
installing net-tools-1.60-691.1
installing patch-2.5.9-260.1
installing perl-base-5.10.0-37.1
installing popt-1.7-427.1
installing zlib-1.2.3-113.1
installing libncurses5-5.6-83.1
installing libbz2-devel-1.0.5-13.1
installing libjpeg-devel-6.2.0-118.1
installing attr-2.4.39-40.1
installing file-4.24-13.1
installing libacl-2.2.45-40.1
installing libreadline5-5.2-71.1
installing perl-5.10.0-37.1
installing acl-2.2.45-40.1
installing bash-3.2-112.1
installing build-2008.06.03-2.1
installing cracklib-2.8.12-24.2
installing insserv-1.11.0-31.1
installing libgcc43-4.3.1_20080507-6.1
installing libgomp43-4.3.1_20080507-6.1
installing libmudflap43-4.3.1_20080507-6.1
installing libuuid1-1.40.8-20.1
installing libzio-0.7-9.1
installing bzip2-1.0.5-13.1
installing timezone-2008b-12.1
WARNING: Not updating /etc/localtime with new zone file
installing less-418-20.1
installing libstdc++43-4.3.1_20080507-6.1
installing info-4.11-16.1
installing pam-1.0.1-8.1
warning: /etc/environment created as /etc/environment.rpmnew
warning: /etc/pam.d/common-account created as /etc/pam.d/common-account.rpmnew
warning: /etc/pam.d/common-auth created as /etc/pam.d/common-auth.rpmnew
warning: /etc/pam.d/common-password created as /etc/pam.d/common-password.rpmnew
warning: /etc/pam.d/common-session created as /etc/pam.d/common-session.rpmnew
warning: /etc/pam.d/other created as /etc/pam.d/other.rpmnew
warning: /etc/securetty created as /etc/securetty.rpmnew
warning: /etc/security/access.conf created as /etc/security/access.conf.rpmnew
warning: /etc/security/group.conf created as /etc/security/group.conf.rpmnew
warning: /etc/security/limits.conf created as /etc/security/limits.conf.rpmnew
warning: /etc/security/namespace.conf created as
/etc/security/namespace.conf.rpmnew
warning: /etc/security/namespace.init created as
/etc/security/namespace.init.rpmnew
warning: /etc/security/pam_env.conf created as /etc/security/pam_env.conf.rpmnew
warning: /etc/security/time.conf created as /etc/security/time.conf.rpmnew
installing binutils-2.18.50.20080409-11.1
installing cpio-2.9-60.1
installing diffutils-2.8.7-118.1
installing findutils-4.4.0-13.1
installing gawk-3.1.5h-37.1
installing grep-2.5.2-73.1
installing gzip-1.3.12-72.1
installing libtool-1.5.26-23.1
installing login-3.36-3.1
installing m4-1.4.11-11.1
installing make-3.81-103.1
installing sed-4.1.5-103.1
installing tar-1.19-35.1
installing gmp-4.2.2-30.1
installing gettext-runtime-0.17-40.1
installing libtiff3-3.8.2-108.1
installing coreutils-6.11-9.1
warning: /etc/default/su created as /etc/default/su.rpmnew
installing texinfo-4.11-16.1
installing linux-kernel-headers-2.6.25-8.1
post linux-kernel-headers-2.6.25-8.1 /var/tmp/rpm-tmp.81297 1
`usr/include/asm' -> `asm-x86'
installing libmpfr1-2.3.1-4.1
installing sysvinit-2.86-148.1
telinit: timeout opening/writing control channel /dev/initctl
installing autoconf-2.61-85.1
installing cvs-1.12.12-126.1
installing psmisc-22.6-30.1
installing groff-1.18.1.1-139.1
Updating etc/sysconfig/suseconfig...
installing cpp43-4.3.1_20080507-6.1
installing automake-1.10.1-25.1
installing glibc-devel-2.8-14.1
installing gettext-tools-0.17-40.1
installing man-2.5.1-12.1
Updating etc/sysconfig/cron...
installing aaa_base-11.0-79.1
warning: /etc/DIR_COLORS created as /etc/DIR_COLORS.rpmnew
warning: /etc/inittab created as /etc/inittab.rpmnew
warning: /root/.exrc created as /root/.exrc.rpmnew
Updating etc/sysconfig/language...
Updating etc/sysconfig/backup...
Updating etc/sysconfig/boot...
Updating etc/sysconfig/kernel...
Updating etc/sysconfig/suseconfig...
Updating etc/sysconfig/clock...
Updating etc/sysconfig/proxy...
Updating etc/sysconfig/windowmanager...
Updating etc/sysconfig/sysctl...
Updating etc/sysconfig/cron...
Updating etc/sysconfig/news...
Updating etc/sysconfig/shutdown...
Updating etc/passwd...unchanged
Updating etc/group...unchanged
Updating etc/shadow...unchanged
installing cpp-4.3-39.1
installing libstdc++43-devel-4.3.1_20080507-6.1
installing zlib-devel-1.2.3-113.1
installing netcfg-11.0-34.1
warning: /etc/HOSTNAME created as /etc/HOSTNAME.rpmnew
installing gcc43-4.3.1_20080507-6.1
installing permissions-2008.6.2-2.1
warning: /etc/permissions.local created as /etc/permissions.local.rpmnew
Updating etc/sysconfig/security...
installing libstdc++-devel-4.3-39.1
installing gcc-4.3-39.1
installing gcc43-c++-4.3.1_20080507-6.1
installing pam-modules-11.0-35.1
installing rpm-4.4.2-199.1
Updating etc/sysconfig/services...
installing util-linux-2.13.1-30.1
warning: /etc/filesystems created as /etc/filesystems.rpmnew
warning: /etc/raw created as /etc/raw.rpmnew
installing gcc-c++-4.3-39.1
installing libtiff-devel-3.8.2-108.1
installing rpmlint-mini-1.0-152.1
installing rpmlint-Factory-1.0-12.1
removing nis flags from //etc/nsswitch.conf...
now finalizing build dir...
Checking permissions and ownerships - using the permissions files
/tmp/Check.perms.aN9BAW
setting /dev/full to root:root 0666. (wrong permissions 0622)
setting /usr/src/packages/SOURCES/ to root:root 1777. (wrong permissions 0755)
setting /usr/src/packages/BUILD/ to root:root 1777. (wrong permissions 0755)
setting /usr/src/packages/RPMS/ to root:root 1777. (wrong permissions 0755)
setting /usr/src/packages/RPMS/athlon/ to root:root 1777. (wrong permissions
0755)
setting /usr/src/packages/RPMS/i386/ to root:root 1777. (wrong permissions 0755)
setting /usr/src/packages/RPMS/i486/ to root:root 1777. (wrong permissions 0755)
setting /usr/src/packages/RPMS/i586/ to root:root 1777. (wrong permissions 0755)
setting /usr/src/packages/RPMS/i686/ to root:root 1777. (wrong permissions 0755)
setting /usr/src/packages/RPMS/noarch/ to root:root 1777. (wrong permissions
0755)
setting /usr/src/packages/SPECS/ to root:root 1777. (wrong permissions 0755)
setting /usr/src/packages/SRPMS/ to root:root 1777. (wrong permissions 0755)
setting /usr/bin/wall to root:tty 2755. (wrong permissions 0755)
setting /usr/bin/write to root:tty 2755. (wrong permissions 0755)
Starting SuSEconfig, the SuSE Configuration Tool...
Running in full featured mode.
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.groff...
Executing /sbin/conf.d/SuSEconfig.permissions...
Finished.
-----------------------------------------------------------------
I have the following modifications for hylafax433.spec:
26c26
< Release: %{release}
---
Release: 7.1
-----------------------------------------------------------------
----- building hylafax433.spec (user abuild)
-----------------------------------------------------------------
-----------------------------------------------------------------
+ exec rpmbuild -ba --eval '%define _srcdefattr (-,root,root)'
/usr/src/packages/SOURCES/hylafax433.spec
error: cannot open Pubkeys index using db3 - No such file or directory (2)

Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.52267
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd /usr/src/packages/BUILD
+ rm -rf hylafax-4.4.4
+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/hylafax-4.4.4.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd hylafax-4.4.4
++ /usr/bin/id -u
+ '[' 399 = 0 ']'
++ /usr/bin/id -u
+ '[' 399 = 0 ']'
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.52267
+ umask 022
+ cd /usr/src/packages/BUILD
+ /bin/rm -rf /var/tmp/hylafax-root
++ dirname /var/tmp/hylafax-root
+ /bin/mkdir -p /var/tmp
+ /bin/mkdir /var/tmp/hylafax-root
+ cd hylafax-4.4.4
+ ./configure --with-DIR_BIN=/usr/bin --with-DIR_SBIN=/usr/sbin
--with-DIR_LIB=/usr/lib --with-DIR_LIBEXEC=/usr/sbin
--with-DIR_LIBDATA=/etc/hylafax --with-DIR_LOCKS=/var/lock
--with-LIBDIR=/usr/lib --with-TIFFBIN=/usr/bin --with-DIR_MAN=/usr/share/man
--with-PATH_GSRIP=/usr/bin/gs --with-DBLIBINC=/usr/include
'--with-LIBTIFF=-ltiff -ljpeg -lz' --with-DIR_SPOOL=/var/spool/hylafax
--with-AFM=no --with-AWK=/usr/bin/gawk --with-PATH_VGETTY=/sbin/vgetty
--with-PATH_GETTY=/sbin/mgetty --with-HTML=no --with-PAGESIZE=A4
--with-PATH_DPSRIP=/var/spool/hylafax/bin/ps2fax --with-PATH_IMPRIP=
--with-SYSVINIT=/etc/init.d/hylafax --with-INTERACTIVE=no

Configuring HylaFAX (tm) (aka FlexFAX) 4.4.4.

If configure does the wrong thing, check the file config.log for
information that may help you understand what went wrong.

Reading site-wide parameters from ./config.site.
YOW!! Did something bad happen or am I on a i686-pc-linux-gnu system?
Using /usr/bin/gcc for a C compiler (set CC to override).
Looks like /usr/bin/gcc supports the -g option.
... but not together with the -O option, not using it.
Looks like /usr/bin/gcc has an ANSI C preprocessor.
... but __ANSI_CPP__ is not automatically defined, will compensate.
Looks like /usr/bin/gcc supports the -M option for generating make dependencies.
Using /usr/bin/g++ for a C++ compiler (set CXX to override).
Looks like /usr/bin/g++ supports the -g option.
Using " -g" for C++ compiler options.
Looks like /usr/bin/g++ has an ANSI C preprocessor.
... but __ANSI_CPP__ is not automatically defined, will compensate.
Using /usr/bin/make to configure the software.
Using "include file" syntax for Makefiles.
Looks like make supports "sinclude" for conditional includes.
Using /bin/bash to process command scripts.

Missing C++ runtime support for g++ (/usr/bin/g++).

Compilation of the following test program failed:

----------------------------------------------------------
#include "iostream.h"
int main(){ cout << "Hello World!" << endl; return 0;}
----------------------------------------------------------

Usually this is because you do not have a standard C++ library
installed on your system or you have installed it in a non-standard
location. If you do not have a C++ library installed, then you must
install it. If it is installed in a non-standard location, then you
should configure the compiler so that it will automatically be found.

(For recent gcc releases this is libstdc++, for older gcc - libg++)

Unrecoverable error! Once you've corrected the problem rerun this script.
error: Bad exit status from /var/tmp/rpm-tmp.52267 (%build)


RPM build errors:
cannot open Pubkeys index using db3 - No such file or directory (2)
Bad exit status from /var/tmp/rpm-tmp.52267 (%build)
md: stopping all md devices.
xenbus_dev_shutdown: device/console/0: Initialising != Connected, skipping
System halted.
< Previous Next >
Follow Ups