Mailinglist Archive: opensuse-buildservice (261 mails)

< Previous Next >
Re: [opensuse-buildservice] Fw: Error in Downloading Packages on an independent setup of Buildservice
  • From: abhijit srivastav <abhijit_s_cvs@xxxxxxxxx>
  • Date: Fri, 20 Jun 2008 01:07:52 -0700 (PDT)
  • Message-id: <530261.70921.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
Thanks Adrian for such a prompt reply.
Regarding the spec file, it is good to know that we will have something new
from you. Even I tried to create a simple spec file creator something like the
KRPM Builder etc. Something like that will be a good option.
For the admin console frontend, the users password cannot be changed as I didnt
find any link to it. Moreover for a distributed environment it is important to
change the password of the Admin.
Lastly, the download option is a problem. For each file that we want to
download it has the same problem.
Regards,
Abhijit  

----- Original Message ----
From: Adrian Schröter <adrian@xxxxxxx>
To: opensuse-buildservice@xxxxxxxxxxxx
Cc: abhijit srivastav <abhijit_s_cvs@xxxxxxxxx>
Sent: Friday, June 20, 2008 9:46:43 AM
Subject: Re: [opensuse-buildservice] Fw: Error in Downloading Packages on an
independent setup of Buildservice


Hello,

On Friday 20 June 2008 09:23:12 abhijit srivastav wrote:
I am a student and am working on my university project regarding the Build
Service. My task is to install the obs packages and try to deliver a full
working architecture of BuildService in our universities architecture.
Presently I am testing it for the openSUSE 10.2 version and so followed the
giudeline present on the net. I was able to install the obs packges and
activate the distribution for openSUSE 10.2. I tried to create a package of
a small software and want to discuss some of the test results.

cool :)

1) The spec file creation does not work. The template file does not exist.

Hm, we removed the template in favor of the new wizard lately.
How do you want to get the template ?

2) I have to login with the Admin rights, what I want to do is to create
different users and allow them to connect to the buildservice and be able
to package their softwares. These is no way to create any users.

There is, just connect with the web browser to the api (by default
http://127.0.42.2). There is an admin interface to manage the users.

3) The download link to the created packages searches the package on the
internet, i.e. official website of openSUSE
https://api.opensuse.org/rpm/home:Admin/openSUSE_10.2/tina/i586/tina-3.7-
8.1.i586.rpm ) instead of the loopback address 127.0.42.1. It appears to
have some configuration errors in the vhosts.d or lighttpd.
What we tried to achieve was to test the buildservice in the independent
environment. Once installed it should work properly on the intranet without
any references to the internet.
I was hoping someone in the forum could help me.

hm, need to look at that ..

bye
adrian

--

Adrian Schroeter
SUSE LINUX Products GmbH, GF: Markus Rex, HRB 16746 (AG Nürnberg)
email: adrian@xxxxxxx


---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx



---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups