Mailinglist Archive: opensuse-buildservice (261 mails)

< Previous Next >
[opensuse-buildservice] Status of openSUSE:Tools:Unstable pkg updates for OBS 1.0 inclusion
  • From: Martin Mohring <martin.mohring@xxxxxxxxx>
  • Date: Wed, 04 Jun 2008 14:31:54 +0200
  • Message-id: <48468B3A.9030003@xxxxxxxxx>
Hi,

again, I have tested the current svn trunc, since OBS 1.0 is nearing. In preparation, I have provided missing packages in openSUSE:Tools:Unstable for inclusion in openSUSE:Tools for OBS 1.0 (currently tested up to svn trunc -r 4100):

- an updated package lzma, which contains the updates from openSUSE:Factory and has a .spec file building for all distros, but debian is not finished. Maybe someone can help me. I have to fix some issues in the debian.tar for lzma. This package should not be build on Mandriva, because Mandriva has a system package for lzma colliding with the packaging of this lzma (shared lib named differently).

- replaced the package "dpkg" by "deb", which is the package provided in openSUSE:Factory for the debian tools "dpkg" etc. I have adapted the .spec file for the other distros to build (not needed on debian based systems).

- updated the obs-server-svn package for svn trunc -r 4100, which has all the newest things inside (build, debtransformer, branching, submission, develproject, hermes, ...)

- updated the individual packages osc-svn and build-svn also to svn trunc -r
4100.


- bs_publisher works for all the target build types, including debian. The problems with
debian builds had been fixed (with "deb" package)

- For older distros, I have also provided "python-gpgme", "python-kid",
"python-setuptools". I seems that openSUSE:Factory has these already inside.

- In order to get bs_publisher work, I also put newer versions of "repoview" and "createrepo" inside. The createrepo is also needed in older distros, since bs_publisher needs at least version 0.4.10, which is currently only met by openSUSE:Factory/openSUSE:11.0

- Also, for some older distros, sufficiently new versions of "yum", "yum-metadata-parser" are provided. I may repeat myself, but only very new Fedora and in fact openSUSE:Factory provide sufficiently new versions.

- Adrian has provided the package "rubygem-builder", so the apidoc gets build
correctly.

- Currently, I am trying to include also a QEMU version sufficently new and configured with the features needed by "build" when QEMU is used. Currently this is an up to date version from openSUSE:Factory, which needs some treatment for use with the other distros to be cross-platform or switched off to be build in case applicable.

I have also written a .spec file that packages all the packages: "build", "osc", "obs-server", "obs-worker", "obs-api" inside one single .spec file. I put that into svn under: "buildservice/dist/obs-server-test.spec". Should I put a project into openSUSE:Tools:Unstable for that? The packages "osc" and "build" are named "build-obs" and "osc-obs", so they are not confused with the original "build" and "osc" packages.
Peter pointed out correctly here that I should unify these .spec files into one
single, with some %if inside.

Conclusion:

If you want to run the soon to be released OBS 1.0 with all functionality working, you have to add a lot of additional packages if you do not run the soon to be released openSUSE 11. We should put a warning inside README/SETUP for that. How far is that tested by you, the user?

Adrian: should openSUSE:Tools:Unstable be the "develproject" for openSUSE:Tools?

I hope this e-mail was not too long...

Keep happy hacking
Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups