Mailinglist Archive: opensuse-buildservice (261 mails)

< Previous Next >
Re: [opensuse-buildservice] Missing important debian functionality
  • From: Martin Mohring <martin.mohring@xxxxxxxxx>
  • Date: Wed, 04 Jun 2008 08:41:16 +0200
  • Message-id: <4846390C.60904@xxxxxxxxx>
Martin Mohring wrote:
Michael Schroeder wrote:
On Fri, May 30, 2008 at 10:14:26AM +0200, Michael Schroeder wrote:
On Fri, May 30, 2008 at 09:18:26AM +0200, Martin Mohring wrote:
i have seen "debtransform" changed in svn. I had fixed it some time ago,
when it didnot work for workers, that do not have XEN, so i tried to
understand it at that time (no full success). I tried now to use the new
version in OBS, and for me it fails now again (for example
openSUSE:Tools/build).

Is the new version not yet finished, or not tested with workers with no XEN?
I don't think XEN can be an issue at all.

Anyway, I saw the chdir() you added, but that breaks the opendir
a couple of lines later if $dir is not an absolute path.
Thus I hunted for the original bug and found a missing "$dir"
when it applies the debtar file. I fixed that and tested it
as good as I could, but it seemed like everything worked. Seems
like I overlooked some other issue.

Argh, fixed it only in one place. Hopefully it works now.
Yes, indeed. I have seen that it is also fixed downstream in factory. Great.

Cheers,
Michael

Michael, tested your fix here now also (after some struggle with the new hermes code which was put in in the middle).
=> debian now works fine so far.
Tnx for the help.
Let run some tests during the night, including local build with osc build for debian/ubuntu targets. That worked also. Great.

Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
List Navigation