Mailinglist Archive: opensuse-buildservice (239 mails)

< Previous Next >
Re: [opensuse-buildservice] Problem linking to another project
  • From: "Archie Cobbs" <archie@xxxxxxxxxxxx>
  • Date: Fri, 2 May 2008 15:08:07 -0500
  • Message-id: <3bc8237c0805021308l6d497e04v9e26db2588cfa71f@xxxxxxxxxxxxxx>
On Fri, May 2, 2008 at 3:03 AM, Michal Marek <mmarek@xxxxxxx> wrote:
I do a search for "js-devel" and find it listed under "OSSP/openSUSE_10.3".

So I try to create a link to my home project from original
project="OSSP" and original package="js-devel".

Result: Unable to find package 'js-devel' in project 'OSSP'.

Links link package sources and 'js-devel' is a subpackage of the 'js'
source package. BTW, to aggregate the js pacage, delete the _link file
and create an _aggregate file instead:
<aggregatelist>
<aggregate project="OSSP">
<package>js</package>
</aggregate>
</aggregatelist>

Thank you!

I deleted the _link and replaced it with an _aggregate file containing
the above contents and it worked.

Now I have another simple/dumb question...

If I search for "openssl-devel" in SuSE 10.3, it is not found (though
"openssl" is found). However a "libopenssl-devel" is found.

On the other hand, I can include a "BuildRequires: openssl-devel" in
my voiceglue.spec file and it will proceed with the build.

So where did the "openssl-devel" package come from? Is it part of
"standard" SuSE? If so, why didn't the search find it?

I guess I'm not clear on what packages can be expected to be found by
a BuildRequires: without having to explicitly _link (or _aggregate) to
them, compared to what you see as part of "openSUSE:10.3/standard" in
the search interface.

Thanks,
-Archie

--
Archie L. Cobbs
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References