Mailinglist Archive: opensuse-buildservice (375 mails)

< Previous Next >
Re: [opensuse-buildservice] Mandriva2008 issues
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Wed, 16 Apr 2008 16:33:28 +0200
  • Message-id: <200804161633.29153.adrian@xxxxxxx>
On Wednesday 16 April 2008 15:37:44 wrote Michal Marek:
Amilcar do Carmo Lucas wrote:
Rebuild i586 expansion error have choice for kernel >= 2.4.18 needed
by alsa-plugins: kernel-desktop586-2.6.22.9-1mdv
kernel-laptop-2.6.22.9-1mdv kernel-server-2.6.22.9-1mdv
kernel-desktop-2.6.22.9-1mdv

I thought that was already fixed in the build config by ignoring the
kernel >= 2.4.18 dependency, Adrian?

No it was made via a Prefer. But I made it wrong and fixed it now.

Rebuild x86_64 expansion error nothing provides libqt3 >= 3.3.2,
nothing provides libqt3-devel >= 3.3.2, nothing provides
libqt3-static-devel >= 3.3.2

You shouldn't use the versioned package names on Mandriva, as these
differ between i586 and x86_64. See an earlier thread with the title
"Mandriva building issues in BS".

well, no this is a special case. Mandriva forgot to add a "Provides: libqt3"
to the lib64qt3 package. So the usual case does not work here.

However, it should work when you "BuildRequires: libqt3-devel". The
lib64qt3-devel should pull the lib64qt3 automatically.


--

Adrian Schroeter
SUSE LINUX Products GmbH, GF: Markus Rex, HRB 16746 (AG Nürnberg)
email: adrian@xxxxxxx

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >