Mailinglist Archive: opensuse-buildservice (219 mails)

< Previous Next >
Re: [opensuse-buildservice] _aggregate from _link
  • From: Marcus Rueckert <darix@xxxxxxxxx>
  • Date: Wed, 20 Feb 2008 13:59:47 +0100
  • Message-id: <20080220125947.GC31080@xxxxxxxxxxxxxxxxxxxxxxx>
On 2008-02-20 13:57:50 +0100, Ladislav Michnovič wrote:
On Feb 20, 2008 2:27 AM, Jeffery Fernandez <jeffery@xxxxxxxxxx> wrote:
Hi all,

I am trying to build with an aggregated package from:

<aggregate project="home:dstoecker">
<package>ocaml</package>
</aggregate>

that package is _linked from project=openSUSE:Factory

When I add a BuildRequires : ocaml = 3.10.0

It just does not build as it complains with:
expansion error: nothing provides ocaml = 3.10.0

If I remove the version number dependency, it pulls out ocaml-3.09.3-37 into
the build environment which I assume is coming from project=openSUSE:Factory

Why do you think that built package from link would have higher
version than origin?
Only release can change and it could be even lower number.

the problem was already solved. he had the _aggregate in a package which
also had a spec file. so the aggregate was ignored. fixing that solve
the problem with building against the aggregated package aswell.

darix

--
openSUSE - SUSE Linux is my linux
openSUSE is good for you
www.opensuse.org
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >