Mailinglist Archive: opensuse-buildservice (219 mails)

< Previous Next >
[opensuse-buildservice] java support
  • From: "John Calcote" <john.calcote@xxxxxxxxx>
  • Date: Tue, 5 Feb 2008 15:38:23 -0700
  • Message-id: <3ee91eb90802051438u20c238ffra4331c1256c1a515@xxxxxxxxxxxxxx>
Hi list,

I wonder if I can get some straight advice on this issue once and for all. :)

I have a package (openxdas) in my home project (jcalcote) that
generates a daemon, written in C, and two client libraries - one
written in C and the other written in pure Java. I've created my
autotools configure.ac and Makefile.am files to build all three
components, but I'm beginning to think that I'm on the bleeding edge
here, functionally speaking.

The java client library builds just fine on my personal SLED 10 system
with IBM Java 1.5 installed. I can even generate source and binaries
rpm files that install just fine. I'm using the following
BuildRequires line in my spec file - both on my system, and in my
project on the build service:

BuildRequires: gcc libgcc java2-devel-packages unixODBC-devel expat

But this only works on a few select platforms. Here's my status page

Debian_Etch
i586 - failed because expat is still 1.0
x86_64 - failed because expat is still 1.0

Fedora_Extras_6
i586 - nothing provides java-1_4_2-sun-devel
x86_64 - nothing provides java-1_4_2-sun-devel

openSUSE_10.2
i586 - nothing provides java-1_5_0-sun-devel
x86_64 - nothing provides java-1_5_0-sun-devel

openSUSE_10.3
i586 - success!
x86_64 - success!

openSUSE_Factory
i586 - java compile problems - bad extension of class Exception.
x86_64 - java compile problems - bad extension of class Exception.

SLES_9
i586 - failed - seems to be an expat library version issue -
undefined reference to XML_StopParser.
x86_64 - failed - seems to be an expat library version issue -
undefined reference to XML_StopParser.

SLE_10
i586 - success!
x86_64 - success!

xUbuntu_7.10
i586 - failed because expat is still 1.0
x86_64 - failed because expat is still 1.0

Fedora_8
i586 - nothing provides java-1_4_2-sun-devel
x86_64 - nothing provides java-1_4_2-sun-devel

Now, I can fix the java compiler issues where I've done something dumb
in my source code - that takes care of the openSUSE_Factory issues I
think. But what can I do about the platforms that want a particular
version of java - expanded I presume from the java2-devel-packages
macro?

1. Am I just going about this the wrong way? Should I stop trying to
compile my java source code in my rpm package, just compile it
separately and provide a java client jar file separately? It should be
portable, since it's java. But is this the right way to do it - should
this stuff be working for me?

2. How I can specify that I want expat 2.0, and not just any old expat library.

Thanks in advance,
John
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages