Mailinglist Archive: opensuse-buildservice (219 mails)

< Previous Next >
Re: [opensuse-buildservice] osc build
  • From: Marcus Rueckert <darix@xxxxxxxxx>
  • Date: Fri, 1 Feb 2008 18:57:25 +0100
  • Message-id: <20080201175725.GA7398@xxxxxxxxxxxxxxxxxxxxxxx>
On 2008-02-01 14:42:08 +0100, Dirk Stoecker wrote:
On Wed, 30 Jan 2008, Marcus Rueckert wrote:

On 2008-01-30 08:46:56 +0100, Dirk Stoecker wrote:
osc build does not clear the build-environment, when the plattform is
changed. So when I switch from 10.2 to 10.3, some packager get
deinstalled
and installed and the result is a (usually not working) mixed setup.

in the general section of ~/.oscrc add:
build-root: /srv/osc/build-root-%(repo)s

then you get one build chroot per repository.

build-root: /srv/osc/build-root-%(repo)s-%(arch)s

is also possible.

now you just have to watch the diskusage.:)

Workarounds are a lot. But the problem is not fixed by these. Under special
conditions this bug may cause hard to track build errors, thus I reported
it. Saving a "This build environment is xxx"-file somewhere in the
build-dir should fix the problem.

can you give examples? testcases?
please be more detailed. such vague statements dont help us to improve
the software.

darix

--
openSUSE - SUSE Linux is my linux
openSUSE is good for you
www.opensuse.org
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References