Mailinglist Archive: opensuse-buildservice (314 mails)

< Previous Next >
[opensuse-buildservice] internal server error with obs-server
  • From: Olaf Hering <olh@xxxxxxx>
  • Date: Sun, 20 Jan 2008 03:37:35 +0100
  • Message-id: <20080120023735.GA14094@xxxxxxx>


I followed the steps from README.SETUP found in obs-server-0.5-3.1.src.rpm
on a fresh 10.3 default kde install. But the docu is either wrong or outdated.

The example described in section 6.1 leads to an internal server error.
lighthttpd does not log anything, so its not clear whats wrong.

# osc -A http://127.0.42.2 meta prj openSUSE:Tools -e

<project name="openSUSE:Tools">

<title>Short title of NewProject</title>

<description>This project aims at providing some foo and bar.

It also does some weird stuff.
</description>

<person role="maintainer" userid="Admin" />

<!-- remove this block to publish your packages on the mirrors -->
<publish>
<disable />
</publish>
<build>
<enable />
</build>
<debuginfo>
<disable />
</debuginfo>

<repository name="openSUSE_10.2">
<path project="openSUSE:10.2" repository="standard"/>
<arch>i586</arch>
</repository>
</project>


"/tmp/osc_metafile.13Ck1R.xml" 61L, 1569C geschrieben
Sending meta data...
Cannot save meta data. Unknown error.
HTTP Error 500: Internal Server Error
Try again? (yY = Yes - nN = No):



Also, something like this should be added to the beginning of the file,
just to make it more clear what needs to be installed:

....
0. install the server
=====================

Do a openSuSE 10.3 default KDE install, configure the network, mail, ntp,
and apply all available update packages.
Add the oss (for ruby-fcgi) and openSuSE:Tools repositories:

# zypper addrepo -n
http://download.opensuse.org/pub/opensuse/distribution/10.3/repo/oss/
openSUSE-10.3-oss
# zypper addrepo -n
http://download.opensuse.org/pub/opensuse/repositories/openSUSE:/Tools/openSUSE_10.3/
openSUSE-10.3-Tools
# zypper refresh

Verify the number of available install sources:

# zypper lr

It should list openSUSE-10.3-DVD, openSUSE-10.3-Updates and the newly added
openSUSE-10.3-Tools.
Install the obs sever packages, this will install also all the dependend
packages:

# zypper install obs-api obs-server obs-worker osc

1. run the backend
....


---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >