Mailinglist Archive: opensuse-buildservice (314 mails)

< Previous Next >
[opensuse-buildservice] A different kernel is installed when installing kmp-packages: Wrong dependencies?
  • From: Johannes Kastl <ojkastl@xxxxxx>
  • Date: Thu, 03 Jan 2008 16:20:16 +0100
  • Message-id: <477CFD30.4090404@xxxxxx>
Hello everyone,

I hope you had a nice new years eve.

I ran into problems a while ago, because when trying to install
truecrypt from the security:/privacy/ repository. When installing the
package truecrypt, it somehow wanted to install trucrypt-kmp-bigsmp,
while I was running kernel-default. So it wanted to install
kernel-bigsmp, too.

I got around that by first installing truecrypt-kmp-default, and then
truecrypt. At least that is what I still remember.

Now I wanted to try asterisk, which is available in the
network:/telephony repo for 10.3. So I added the repo in apt, and tried
to install, and again something strange happens:

#apt-get install asterisk -s
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
... kernel-bigsmp kernel-xen kernel-xenpae
... xen
... zaptel zaptel-kmp-bigsmp

Note that it wants to install zaptel-kmp-bigsmp, even if there is a
kmp-default package. Also it wants to install different kernels, and
xen, and I do not know why I would need xen to run asterisk.

I asked the maintainer, and we are still discussing. He couldn*t
reproduce this behaviour, I think because he already has a different
kernel. But Im waiting for his answer on this.

I then set up 10.2 minimal install in a VM, and installed asterisk (an
older version) out of the 10.2 update repo. No problems.
But when adding the network:/telephony repo, and trying to install the
newer asterisk version, again I get:

#apt-get install asterisk -s
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
iksemel kernel-bigsmp kernel-xen kernel-xenpae libogg libpri libvorbis
mISDN mISDNuser newt openldap2 postgresql-libs slang
speex unixODBC xen zaptel zaptel-kmp-bigsmp
The following packages will be upgraded
asterisk

I could install iksemel libogg libpri libvorbis newt openldap2
postgresql-libs slang speex unixODBC without any problems, but when
trying to install zaptel, apt tries to install xen and the kernels.

What is going wrong there? Wrong dependencies in the packages? Problems
on my machines? Problem in apt (which I doubt, cos I tried zypper as well)?

Could someone try this? I think it might be a problem with the
kmp-packages, but I know to little about rpms+specs to go further into
detail.

Thanks,
OJ
--
`You can do magic! Surely you can sort out - well - anything!´
Scrimgeour [...] exchanged an incredulous look with Fudge, who really
did manage a smile this time as he said kindly, `The trouble is, the
other side can do magic too, Prime Minister.´ (Harry Potter 6)

< Previous Next >