Mailinglist Archive: opensuse-buildservice (314 mails)

< Previous Next >
Re: [opensuse-buildservice] failed to build sysvinit
  • From: Martin Pley <pley@xxxxxx>
  • Date: Wed, 2 Jan 2008 18:37:13 +0100
  • Message-id: <200801021837.13637.pley@xxxxxx>
Am Mittwoch, 2. Januar 2008 14:51:57 schrieb Adrian Schröter:
On Wednesday 02 January 2008 13:50:34 wrote Michal Marek:
Martin Pley wrote:
My sysvinit package in home:pley fails to build. The RPMs are created
but the status afther finishing is "failed". The last lines from build
log:

[...]
/bin/bash: halt: command not found
Kernel panic - not syncing: Attempted to kill init!

The buildservice normally doesn't install packages into the chroot if
it's going to build the same package from source. E.g. libtool is always
installed, except when building libtool itself. But certain packages
need to be installed anyway, for instance 'make' or 'rpm' are always
present. It turns out that sysvinit is also one of these, because the
virtual machine doesn't shutdown otherwise.

=> adrian/darix/mls: sysvinit needs to be added to the Keep: set in the
distro configs.

We can build sysvinfo also in openSUSE:Factory without that, so this seems
not to be the reason.

these both error messages can be ignored (but we should fix them anyway to
avoid confusion), there is another line regarding / in /etc/fstab, I dunno
yet, if this is the reason ....

I'd like to ignore them, but the RPMs are not copied out of the chroot
enviroment. Thus they are deleted right after creation.
If sysvinit is really not installed, as Michal told, then maybe the
fstab-error-message is there because "/bin/mountpoint" is missing.
However, I cannot believe that the build-chroot-env works without sysvinit.

Kind regards
Martin
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
List Navigation