Mailinglist Archive: opensuse-buildservice (170 mails)

< Previous Next >
Re: [opensuse-buildservice] expansion error
  • From: Ben Martin <monkeyiq@xxxxxxxxxxxxxxxxxxxxx>
  • Date: Thu, 20 Dec 2007 18:34:24 +1000
  • Message-id: <1198139664.27014.51.camel@xxxxxxxxxxxxxxx>

On Thu, 2007-12-20 at 09:27 +0100, Adrian Schröter wrote:
On Thursday 20 December 2007 06:24:38 wrote Jasem Mutlaq:
Hello,

I tried the build service for the first time today, and I was quite amazed
how handy and versatile it is!

My package requires fxload, and this didn't pose any problems under
OpenSUSE 10.3 and Fedora 8, but for xUbuntu 7.10 I got the following error:

expansion error nothing provides fxload

What would be the resolution for this problem?

It seems this package is not provided for Ubuntu ?

Maybe under a different name, in that case we can map the name. However, it
would be cool, if you can find out what is the status in Ubuntu of that
package :)

The problem is that fxload is in Universe and not the core 7.10 distro.
http://packages.ubuntu.com/gutsy/admin/fxload
My adhoc solution to this for my builds has been to import the source
from ubuntu universe into a subproject and link that to my ubuntu 7.10
repository.

Perhaps the entire ubuntu universe can be added to OBS? I'm not sure of
the overall size but it would be nice to be able to just target
ubuntu 7.10 + universe
when building packages with OBS.


< Previous Next >
Follow Ups