Mailinglist Archive: opensuse-buildservice (287 mails)

< Previous Next >
[opensuse-buildservice] Problems building gizmod package on build server -- works fine locally...?
Hi all.

I posted this on IRC (via pastebin.com) but there wasn't anyone there that could see what the issue was here.
I am guessing there's a dependency missing, but it really puzzles me that it complains about the boost library which *is* installed... Here follows my tale of woe:

I have built gizmod 3.3 on my openSUSE beta2 without issue but on the
buildservice in the automated xen-environment, it cannot find the boost
library, even though it gets installed during startup.

I have tried with just '--with-boost' (worked on my machine) and
'--with-boost=/usr' (hoping it would help, but alas...)

I am at a loss as to why this is a problem. I could understand if there was a
dependency I hadn't mentioned in the .spec file, but that doesn't seem to be
the case...

In case it can help narrow it down, heres an ldd dump of the gizmod binary:

dualpc:/home/martin/Documents # ldd /usr/bin/gizmod
        linux-gate.so.1 =>  (0xffffe000)
        libH.so.3 => /usr/lib/libH.so.3 (0xb7f2d000)
        libGizmod.so.3 => /usr/lib/libGizmod.so.3 (0xb7e95000)
        libboost_program_options.so.1.33.1 =>
/usr/lib/libboost_program_options.so.1.33.1 (0xb7e5d000)
        libboost_filesystem.so.1.33.1 => /usr/lib/libboost_filesystem.so.1.33.1
(0xb7e4b000)
        libboost_thread-mt.so.1.33.1 => /usr/lib/libboost_thread-mt.so.1.33.1
(0xb7e3e000)
        libpython2.5.so.1.0 => /usr/lib/libpython2.5.so.1.0 (0xb7d1c000)
        libboost_python.so.1.33.1 => /usr/lib/libboost_python.so.1.33.1
(0xb7ce1000)
        libboost_serialization.so.1.33.1 =>
/usr/lib/libboost_serialization.so.1.33.1 (0xb7c87000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb7b6c000)
        libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0xb7b69000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb7b4f000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb7b4b000)
        libdl.so.2 => /lib/libdl.so.2 (0xb7b47000)
        libasound.so.2 => /usr/lib/libasound.so.2 (0xb7a8b000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb799d000)
        libm.so.6 => /lib/libm.so.6 (0xb7978000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb796c000)
        libc.so.6 => /lib/libc.so.6 (0xb7839000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb7822000)
        librt.so.1 => /lib/librt.so.1 (0xb7819000)
        libutil.so.1 => /lib/libutil.so.1 (0xb7815000)
        /lib/ld-linux.so.2 (0xb7f76000)

It failed on 10.2, 10.3 and openSUSE Factory. Haven't tried any others.

And here's the log for the latest failed build:

build16 started "build gizmod.spec" at Thu Sep 20 21:22:01 UTC 2007.

Building gizmod for project 'home:martinm_76' repository 'openSUSE_Factory'
arch 'x86_64' srcmd5 '26dd181f692bed06aa1f706afdb1dd97
Using BUILD_ROOT=/abuild/root_2/.mount
Using BUILD_ARCH=x86_64:i686:i586:i486:i386
Doing XEN build in /abuild/root_2/root

processing specfile /abuild/root_2/.build-srcdir/gizmod.spec...
running changelog2spec --target rpm --file
/abuild/root_2/.build-srcdir/gizmod.spec
init_buildsystem --rpmlist /abuild/root_2/.rpmlist gizmod.spec ...
preinstalling aaa_base...
preinstalling acl...
preinstalling attr...
preinstalling bash...
preinstalling coreutils...
preinstalling diffutils...
preinstalling filesystem...
preinstalling fillup...
preinstalling glibc...
preinstalling grep...
preinstalling insserv...
preinstalling libacl...
preinstalling libattr...
preinstalling libbz2-1...
preinstalling libgcc42...
preinstalling libxcrypt...
preinstalling m4...
preinstalling ncurses...
preinstalling pam...
preinstalling permissions...
preinstalling popt...
preinstalling libreadline5...
preinstalling rpm...
preinstalling sed...
preinstalling tar...
preinstalling zlib...
preinstalling util-linux...
preinstalling perl-base...
preinstalling libdb-4_5...
preinstalling libvolume_id...
copying packages...
reordering...done
starting xen virtual machine
Bootdata ok (command line is root=/dev/hda1 ro init=/.build/build panic=1
console=ttyS0)
Linux version 2.6.16.46-0.7-xen (geeko@buildhost) (gcc version 4.1.2 20070115
(prerelease) (SUSE Linux)) #1 SMP Mon Apr 23 16:13:18 UTC 2007
BIOS-provided physical RAM map:
Xen: 0000000000000000 - 000000002f600000 (usable)
No mptable found.
Built 1 zonelists
Kernel command line: root=/dev/hda1 ro init=/.build/build panic=1 console=ttyS0
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 131072 bytes)
Xen reported: 2210.186 MHz processor.
Console: colour dummy device 80x25
Dentry cache hash table entries: 131072 (order: 8, 1048576 bytes)
Inode-cache hash table entries: 65536 (order: 7, 524288 bytes)
Software IO TLB disabled
Memory: 740732k/776192k available (1902k kernel code, 26572k reserved, 798k
data, 160k init)
Calibrating delay using timer specific routine.. 5527.67 BogoMIPS
(lpj=11055343)
Security Framework v1.0.0 initialized
Mount-cache hash table entries: 256
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 1024K (64 bytes/line)
checking if image is initramfs... it is
Freeing initrd memory: 7436k freed
Brought up 1 CPUs
migration_cost=0
DMI not present or invalid.
Grant table initialized
NET: Registered protocol family 16
Brought up 1 CPUs
PCI: setting up Xen PCI frontend stub
ACPI: Subsystem revision 20060127
ACPI: Interpreter disabled.
xen_mem: Initialising balloon driver.
Setting mem allocation to 768000 kiB
PCI: System does not support PCI
PCI: System does not support PCI
IA32 emulation $Id: sys_ia32.c,v 1.32 2002/03/24 13:02:28 ak Exp $
audit: initializing netlink socket (disabled)
audit(1190323342.025:1): initialized
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
Initializing Cryptographic API
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
rtc: IRQ 8 is not free.
Non-volatile memory driver v1.2
i8042.c: No controller found.
RAMDISK driver initialized: 16 RAM disks of 128000K size 1024 blocksize
xencons_init: Initializing xen vfb; pass xencons=tty to prevent this
Xen virtual console successfully installed as xvc0
Event-channel device installed.
mice: PS/2 mouse device common for all mice
input: PC Speaker as /class/input/input0
md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 4.39
NET: Registered protocol family 2
IP route cache hash table entries: 32768 (order: 6, 262144 bytes)
TCP established hash table entries: 131072 (order: 9, 2097152 bytes)
TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
NET: Registered protocol family 1
XENBUS: Device with no driver: device/vbd/769
XENBUS: Device with no driver: device/vbd/770
XENBUS: Device with no driver: device/console/0
Starting udevd
Creating devices
Loading xennet
netfront: Initialising virtual ethernet driver.
Loading xenblk
Registering block device major 3
blkfront: hda1: barriers enabled
blkfront: hda2: barriers enabled
Loading reiserfs
Loading jbd
Loading ext3
Waiting for device /dev/hda1 to appear: ok
rootfs: major=3 minor=1 devn=769
Mounting root /dev/hda1
ReiserFS: hda1: found reiserfs format "3.6" with standard journal
ReiserFS: hda1: using ordered data mode
reiserfs: using flush barriers
ReiserFS: hda1: journal params: device hda1, size 8192, journal first block 18,
max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hda1: checking transaction log (hda1)
ReiserFS: hda1: Using r5 hash to sort names
machine type: x86_64
reiserfs: enabling write barrier flush mode
swapon on /dev/hda2
Adding 1025016k swap on /dev/hda2. Priority:-1 extents:1 across:1025016k
logging output to //.build.log...
build16 started "build gizmod.spec" at Thu Sep 20 21:22:24 UTC 2007.

Building gizmod for project 'home:martinm_76' repository 'openSUSE_Factory'
arch 'x86_64' srcmd5 '26dd181f692bed06aa1f706afdb1dd97
Using BUILD_ROOT=/
Using BUILD_ARCH=x86_64:i686:i586:i486:i386

processing specfile /.build-srcdir/gizmod.spec...
init_buildsystem gizmod.spec ...
running aaa_base preinstall script
running aaa_base postinstall script
Updating etc/sysconfig/language...
Updating etc/sysconfig/backup...
Updating etc/sysconfig/boot...
Updating etc/sysconfig/kernel...
Updating etc/sysconfig/suseconfig...
Updating etc/sysconfig/clock...
Updating etc/sysconfig/proxy...
Updating etc/sysconfig/windowmanager...
Updating etc/sysconfig/sysctl...
Updating etc/sysconfig/cron...
Updating etc/sysconfig/news...
Updating etc/sysconfig/shutdown...
Updating etc/sysconfig/sw_management...
Updating etc/passwd...unchanged
Updating etc/group...unchanged
Updating etc/shadow...new
initializing rpm db...
installing filesystem-10.3-47
installing glibc-2.6.1-12
warning: /etc/bindresvport.blacklist created as
/etc/bindresvport.blacklist.rpmnew
warning: /etc/default/nss created as /etc/default/nss.rpmnew
warning: /etc/nsswitch.conf created as /etc/nsswitch.conf.rpmnew
warning: /etc/rpc created as /etc/rpc.rpmnew
installing audit-libs-1.5.5-10
installing cpp42-4.2.1_20070724-12
installing fillup-1.42-176
installing gdbm-1.8.3-299
installing glibc-locale-2.6.1-12
installing libattr-2.4.28-78
installing libbz2-1-1.0.4-39
installing libdb-4_5-4.5.20-26
installing libltdl-3-1.5.24-14
installing libxcrypt-2.4-68
installing mktemp-1.5-801
installing ncurses-5.6-37
installing net-tools-1.60-647
installing patch-2.5.9-216
installing perl-base-5.8.8-73
installing pkg-config-0.21-35
installing popt-1.7-364
installing xorg-x11-libICE-7.2-57
installing xorg-x11-libXau-7.2-50
installing xorg-x11-libXdmcp-7.2-49
installing zlib-1.2.3-72
installing libbz2-devel-1.0.4-39
installing zlib-devel-1.2.3-72
installing attr-2.4.28-78
installing file-4.21-4
installing freetype2-2.3.5-15
installing libacl-2.2.34-72
installing libreadline5-5.2-15
installing xorg-x11-libSM-7.2-54
installing xorg-x11-libfontenc-7.2-55
installing xorg-x11-libxcb-7.2-46
installing acl-2.2.34-72
installing bash-3.2-56
installing xorg-x11-proto-devel-7.2-62
installing cpp-4.2-21
installing cracklib-2.8.10-34
installing insserv-1.09.0-43
installing libasound2-1.0.14-27
installing libexpat1-2.0.1-21
installing libgcc42-4.2.1_20070724-12
installing libgomp42-4.2.1_20070724-12
installing libmudflap42-4.2.1_20070724-12
installing libuuid1-1.40.2-15
installing libvisual-0.4.0-79
installing libvolume_id-114-10
installing libzio-0.4-40
installing bzip2-1.0.4-39
installing freetype2-devel-2.3.5-15
installing timezone-2007g-4
WARNING: Not updating /etc/localtime with new zone file
installing xorg-x11-libX11-7.2-70
installing less-406-11
installing libexpat-devel-2.0.1-21
installing libvisual-devel-0.4.0-79
installing xorg-x11-libXfixes-7.2-59
installing xorg-x11-libXrender-7.2-59
installing xorg-x11-libxkbfile-7.2-58
installing xorg-x11-xtrans-devel-7.2-52
installing libstdc++42-4.2.1_20070724-12
installing xorg-x11-fonts-devel-7.2-49
installing xorg-x11-libXau-devel-7.2-50
installing xorg-x11-libXdmcp-devel-7.2-49
installing xorg-x11-libXext-7.2-59
installing xorg-x11-libfontenc-devel-7.2-55
installing xorg-x11-libXt-7.2-60
installing xorg-x11-util-devel-7.2-50
installing fontconfig-2.4.2-40
installing info-4.9-12
installing pam-0.99.8.1-12
warning: /etc/environment created as /etc/environment.rpmnew
warning: /etc/pam.d/common-account created as /etc/pam.d/common-account.rpmnew
warning: /etc/pam.d/common-auth created as /etc/pam.d/common-auth.rpmnew
warning: /etc/pam.d/common-password created as
/etc/pam.d/common-password.rpmnew
warning: /etc/pam.d/common-session created as /etc/pam.d/common-session.rpmnew
warning: /etc/pam.d/other created as /etc/pam.d/other.rpmnew
warning: /etc/securetty created as /etc/securetty.rpmnew
warning: /etc/security/access.conf created as /etc/security/access.conf.rpmnew
warning: /etc/security/group.conf created as /etc/security/group.conf.rpmnew
warning: /etc/security/limits.conf created as /etc/security/limits.conf.rpmnew
warning: /etc/security/namespace.conf created as
/etc/security/namespace.conf.rpmnew
warning: /etc/security/namespace.init created as
/etc/security/namespace.init.rpmnew
warning: /etc/security/pam_env.conf created as
/etc/security/pam_env.conf.rpmnew
warning: /etc/security/time.conf created as /etc/security/time.conf.rpmnew
installing automake-1.10-43
installing binutils-2.17.50.20070726-10
installing cpio-2.9-14
installing diffutils-2.8.7-77
installing findutils-4.2.31-21
installing gawk-3.1.5g-22
installing grep-2.5.2-25
installing gzip-1.3.12-31
installing libtool-1.5.24-14
installing m4-1.4.10-14
installing make-3.81-62
installing sed-4.1.5-61
installing tar-1.17-18
installing xorg-x11-libXv-7.2-55
installing xorg-x11-libxcb-devel-7.2-46
installing libicu-3.6-10
installing xorg-x11-libICE-devel-7.2-57
installing xorg-x11-libXp-7.2-54
installing gettext-0.16-43
installing coreutils-6.9-40
warning: /etc/default/su created as /etc/default/su.rpmnew
installing cvs-1.12.12-82
installing xorg-x11-libXmu-7.2-59
installing texinfo-4.9-12
installing xorg-x11-libXpm-7.2-59
installing linux-kernel-headers-2.6.22-15
post linux-kernel-headers-2.6.22-15 /var/tmp/rpm-tmp.91163 1
`usr/include/asm' -> `asm-bi-x86_64'
installing sysvinit-2.86-99
telinit: timeout opening/writing control channel /dev/initctl
installing autoconf-2.61-44
installing xorg-x11-libSM-devel-7.2-54
installing boost-1.33.1-102
installing xorg-x11-libX11-devel-7.2-70
installing xorg-x11-libXprintUtil-7.2-54
installing groff-1.18.1.1-96
Updating etc/sysconfig/suseconfig...
installing perl-5.8.8-73
Updating etc/sysconfig/suseconfig...
installing aaa_base-10.3-78
warning: /etc/DIR_COLORS created as /etc/DIR_COLORS.rpmnew
warning: /etc/inittab created as /etc/inittab.rpmnew
warning: /root/.exrc created as /root/.exrc.rpmnew
Updating etc/sysconfig/language...
Updating etc/sysconfig/backup...
Updating etc/sysconfig/boot...
Updating etc/sysconfig/kernel...
Updating etc/sysconfig/suseconfig...
Updating etc/sysconfig/clock...
Updating etc/sysconfig/proxy...
Updating etc/sysconfig/windowmanager...
Updating etc/sysconfig/sysctl...
Updating etc/sysconfig/cron...
Updating etc/sysconfig/news...
Updating etc/sysconfig/shutdown...
Updating etc/sysconfig/sw_management...
Updating etc/passwd...unchanged
Updating etc/group...unchanged
Updating etc/shadow...unchanged
installing boost-devel-1.33.1-102
installing netcfg-10.3-36
warning: /etc/HOSTNAME created as /etc/HOSTNAME.rpmnew
installing glibc-devel-2.6.1-12
installing permissions-2007.8.10-8
warning: /etc/permissions.local created as /etc/permissions.local.rpmnew
Updating etc/sysconfig/security...
installing xorg-x11-libXext-devel-7.2-59
installing xorg-x11-libXfixes-devel-7.2-59
installing xorg-x11-libXrender-devel-7.2-59
installing xorg-x11-libxkbfile-devel-7.2-58
installing man-2.4.3-81
Updating etc/sysconfig/cron...
installing xorg-x11-libXt-devel-7.2-60
installing xorg-x11-libs-7.2-96
installing alsa-devel-1.0.14-27
installing fontconfig-devel-2.4.2-40
installing gettext-devel-0.16-43
installing pam-modules-10.3-44
installing gcc42-4.2.1_20070724-12
installing xorg-x11-libXp-devel-7.2-54
installing xorg-x11-libXv-devel-7.2-55
installing rpm-4.4.2-136
Updating etc/sysconfig/services...
installing xorg-x11-libXmu-devel-7.2-59
installing xorg-x11-libXpm-devel-7.2-59
installing util-linux-2.12r+2.13rc2+git20070725-18
warning: /etc/filesystems created as /etc/filesystems.rpmnew
warning: /etc/raw created as /etc/raw.rpmnew
installing gcc-4.2-21
installing xorg-x11-libXprintUtil-devel-7.2-54
installing xorg-x11-devel-7.2-96
removing nis flags from //etc/nsswitch.conf...
now finalizing build dir...
Checking permissions and ownerships - using the permissions files
/tmp/Check.perms.BV2049
setting /usr/src/packages/SOURCES/ to root:root 1777. (wrong permissions 0755)
setting /usr/src/packages/BUILD/ to root:root 1777. (wrong permissions 0755)
setting /usr/src/packages/RPMS/ to root:root 1777. (wrong permissions 0755)
setting /usr/src/packages/RPMS/x86_64/ to root:root 1777. (wrong permissions
0755)
setting /usr/src/packages/RPMS/noarch/ to root:root 1777. (wrong permissions
0755)
setting /usr/src/packages/SPECS/ to root:root 1777. (wrong permissions 0755)
setting /usr/src/packages/SRPMS/ to root:root 1777. (wrong permissions 0755)
setting /usr/bin/wall to root:tty 2755. (wrong permissions 0755)
setting /usr/bin/write to root:tty 2755. (wrong permissions 0755)
Starting SuSEconfig, the SuSE Configuration Tool...
Running in full featured mode.
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.groff...
Executing /sbin/conf.d/SuSEconfig.perl...
Executing /sbin/conf.d/SuSEconfig.permissions...
Finished.
-----------------------------------------------------------------
I have the following modifications for gizmod.spec:
3c3
< Release: 0
---
> Release: 2.1
-----------------------------------------------------------------
----- building gizmod.spec (user abuild)
-----------------------------------------------------------------
-----------------------------------------------------------------

Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.82192
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd /usr/src/packages/BUILD
+ rm -rf gizmod-3.3
+ /usr/bin/bzip2 -dc /usr/src/packages/SOURCES/gizmod-3.3.tar.bz2
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd gizmod-3.3
++ /usr/bin/id -u
+ '[' 99 = 0 ']'
++ /usr/bin/id -u
+ '[' 99 = 0 ']'
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.82192
+ umask 022
+ cd /usr/src/packages/BUILD
+ /bin/rm -rf /var/tmp/gizmod-root
++ dirname /var/tmp/gizmod-root
+ /bin/mkdir -p /var/tmp
+ /bin/mkdir /var/tmp/gizmod-root
+ cd gizmod-3.3
+ CFLAGS=-O2
+ CXXFLAGS=-O2
+ ./configure --prefix=/usr --sysconfdir=/etc --with-boost=/usr
--enable-visplugin
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking dependency style of g++... none
checking for a BSD-compatible install... /usr/bin/install -c
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for ld used by gcc... /usr/x86_64-suse-linux/bin/ld
checking if the linker (/usr/x86_64-suse-linux/bin/ld) is GNU ld... yes
checking for /usr/x86_64-suse-linux/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for g77... no
checking for xlf... no
checking for f77... no
checking for frt... no
checking for pgf77... no
checking for cf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for xlf90... no
checking for f90... no
checking for pgf90... no
checking for pghpf... no
checking for epcf90... no
checking for gfortran... no
checking for g95... no
checking for xlf95... no
checking for f95... no
checking for fort... no
checking for ifort... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for ftn... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether accepts -g... no
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking for correct ltmain.sh version... yes
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking whether the gcc linker (/usr/x86_64-suse-linux/bin/ld -m elf_x86_64)
supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... cat: /etc/ld.so.conf.d/*.conf: No
such file or directory
GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
configure: creating libtool
appending configuration tag "CXX" to libtool
appending configuration tag "F77" to libtool
checking for boostlib >= 1.33.1... configure: error: We could not detect the
boost libraries (version 1.33 or higher). If you have a staged boost library
(still not installed) please specify $BOOST_ROOT in your environment and do not
give a PATH to --with-boost option. If you are sure you have boost installed,
then check your version number looking in <boost/version.hpp>. See
http://randspringer.de/boost for more documentation.
error: Bad exit status from /var/tmp/rpm-tmp.82192 (%build)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.82192 (%build)
mount: can't find / in /etc/fstab or /etc/mtab
md: stopping all md devices.
xenbus_dev_shutdown: device/console/0: Initialising != Connected, skipping
System halted.

gizmod.spec:
Name: gizmod
Version: 3.3
Release: 0
Packager: Martin Moeller <martin@xxxxxxxxxxxxx>
URL: http://gizmod.sf.net
Source: %{name}-%{version}.tar.bz2
Summary: Gizmod is an advanced input handler for keyboards, mice, etc...
Group: Userspace/Input
License: Apache License V2.0

BuildRoot: %{_tmppath}/%{name}-root
Provides: gizmod
BuildRequires: boost-devel libvisual-devel alsa-devel xorg-x11-devel
Requires: python boost libvisual alsa xorg-x11

%description
Gizmod is an input handler that binds to a specific device and can
adapt to various situations so you can have one meaning in, say, AmaroK
and another in MPlayer, etc. It even includes remote control so you can
send input events to another machine with a locally connected device.

%changelog
* Thu Sep 20 2007 Martin Moeller <martin@xxxxxxxxxxxxx> 3.3-0
- initial version

%prep
%setup -q

%build
CFLAGS="-O2" CXXFLAGS="-O2" ./configure --prefix=/usr --sysconfdir=/etc --with-boost --enable-visplugin
make

%install
if [ ! %{buildroot} = "/" ]; then %{__rm} -rf %{buildroot}; fi
make DESTDIR=%{buildroot} install

%clean
if [ ! %{buildroot} = "/" ]; then %{__rm} -rf %{buildroot}; fi
#rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%doc AUTHORS ChangeLog COPYING INSTALL NEWS NOTICE README TODO
%{_prefix}/bin/*
%{_prefix}/lib/*
%{_prefix}/include/*
/etc/*



Regards,

/Martin.

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >