Mailinglist Archive: opensuse-buildservice (287 mails)

< Previous Next >
Re: [opensuse-buildservice] expansion error: have choice for
  • From: Michal Marek <mmarek@xxxxxxx>
  • Date: Wed, 19 Sep 2007 14:59:48 +0200
  • Message-id: <46F11D44.6040703@xxxxxxx>
Ales Nosek wrote:
> Package 'A' has BuildRequires which can be solved by packages 'B' and
> 'C' which are also part of the project.
> This results in "expansion error: have choice for ....".
> 
> Is there a workaround for this? We don't want to change the
> BuildRequires of package 'A'.
> How could we tell BS that for our project it should always prefer
> package 'B' to 'C' when solving BuildRequires?

You can add 'Prefer: package' (to pick this one) or 'Prefer: -package'
(to ignore this one) to the project config (osc meta -e prjconf <project>).

hth,
Michal
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
References