Mailinglist Archive: opensuse-buildservice (287 mails)

< Previous Next >
[opensuse-buildservice] expansion error; How to fix?
  • From: Paul Elliott <pelliott@xxxxxx>
  • Date: Thu, 13 Sep 2007 16:49:22 -0500
  • Message-id: <20070913214922.GA6922@xxxxxx>
When I attempt to build the peless project:
http://build.opensuse.org/package/show?project=home%3Apelliott11&package=peless

under ubuntu 7.04 I get the following error message:
expansion error

nothing provides libboost-regex-dev, nothing provides libboost-filesystem-dev

I think this is because these packages are in the universe repository:
http://packages.ubuntu.com/cgi-bin/search_packages.pl?keywords=libboost-regex-dev&searchon=names&subword=1&version=feisty&release=all

http://packages.ubuntu.com/cgi-bin//search_packages.pl?version=feisty&subword=1&exact=&arch=any&releases=all&case=insensitive&keywords=libboost-filesystem-dev&searchon=names

Is there anyway around this to make these packages
available for my build?


peless also fails to build under debian etch, but
it gets a different expansion error:

have choice for libstdc++-dev needed by libboost-dev: libstdc++2.10-dev libstdc++6-4.1-dev libstdc++6-dev libstdc++5-3.3-dev, have choice for libstdc++-dev needed by libsigc++-2.0-dev: libstdc++2.10-dev libstdc++6-4.1-dev libstdc++6-dev libstdc++5-3.3-dev


I guess libstdc++dev is an indrect dependancy but there are
multiple versions that supply the dependancy and the build service
can not decide which version to supply?

Is there a workaround for this?

Thank You.

-- 
Paul Elliott                       1(512)837-1096
pelliott@xxxxxx                    PMB 181, 11900 Metric Blvd Suite J
http://www.io.com/~pelliott/pme/   Austin TX 78758-3117
< Previous Next >
This Thread
  • No further messages