Mailinglist Archive: opensuse-buildservice (287 mails)

< Previous Next >
[opensuse-buildservice] Installing local OBS?
  • From: Rauch Christian <lists@xxxxxxxxxxxxxx>
  • Date: Sat, 08 Sep 2007 17:01:21 +0200
  • Message-id: <46E2B941.4030608@xxxxxxxxxxxxxx>
Hi list,

today I tried installing my local OBS here according to [1].

System is the following:

VMWare Server running on 10.2 machine (Athlon 64 X2, 2 gig ram)
Suse 10.2 installed in VMWare, minimal setup, no zmd, all updates
installed.

Installed mysql, obs-api, obs-worker, obs-server from [2], created
database, started worker and so on.

Then it comes to calling "rake migrate" in /srv/www/obs/frontend/, which
fails completely.

At first the following comes up:

----------------------------------------------------------------------------
obs:/srv/www/obs/frontend/config # rake migrate
/usr/bin/rake:17:Warning: require_gem is obsolete.  Use gem instead.
(in /srv/www/obs/frontend)
Cannot find gem for Rails ~>1.2.3.0:
    Install the missing gem with 'gem install -v=1.2.3 rails', or
    change environment.rb to define RAILS_GEM_VERSION with your desired
version.

rake aborted!
exit
/srv/www/obs/frontend/Rakefile:4
(See full trace by running task with --trace)
----------------------------------------------------------------------------

So i checked to see which rails version I have and changed
RAILS_GEM_VERSION to 1.1.6, which changes the error to the following:

----------------------------------------------------------------------------
obs:/srv/www/obs/frontend # rake --trace migrate
/usr/bin/rake:17:Warning: require_gem is obsolete.  Use gem instead.
(in /srv/www/obs/frontend)
** Invoke migrate (first_time)
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
>>>>>>>>>>>>>>>>>>>>>>> /srv/www/obs/common/lib <<<<<<<<<<<<<<<<<<<<<<<<<<
Using global environment
/srv/www/obs/frontend/config/../config/environments/development_base.rb
Using global environment
/srv/www/obs/frontend/config/../config/environments/development_base.rb
rake aborted!
uninitialized constant DynamicSegment
/usr/lib64/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:123:in
`const_missing'
/srv/www/obs/frontend/config/../lib/rails_unescape_fix.rb:7
/usr/lib64/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
/usr/lib64/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:27:in `require'
/usr/lib64/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
`require'
/srv/www/obs/frontend/config/../config/environment.rb:90
/usr/lib64/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
/usr/lib64/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:27:in `require'
/usr/lib64/ruby/gems/1.8/gems/rails-1.1.6/lib/tasks/misc.rake:3
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:in `call'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:in `execute'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:in `each'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:in `execute'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:357:in `invoke'
/usr/lib64/ruby/1.8/thread.rb:135:in `synchronize'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:in `invoke'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:364:in
`invoke_prerequisites'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:999:in `each'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:999:in `send'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:999:in `each'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:363:in
`invoke_prerequisites'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:356:in `invoke'
/usr/lib64/ruby/1.8/thread.rb:135:in `synchronize'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:in `invoke'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:364:in
`invoke_prerequisites'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:999:in `each'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:999:in `send'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:999:in `each'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:363:in
`invoke_prerequisites'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:356:in `invoke'
/usr/lib64/ruby/1.8/thread.rb:135:in `synchronize'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:in `invoke'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in `run'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in `each'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in `run'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/bin/rake:7
/usr/bin/rake:18:in `load'
/usr/bin/rake:18
----------------------------------------------------------------------------

>From there I am really lost now. Any hints anyone?

Regards,

Chris

[1]http://en.opensuse.org/Build_Service/Build_Service_Installation_Tutorial/openSUSE_10.2
[2]http://ftp5.gwdg.de/pub/opensuse/repositories/openSUSE:/Tools/openSUSE_10.2/
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups