Mailinglist Archive: opensuse-buildservice (366 mails)

< Previous Next >
[opensuse-buildservice] Problem with Requires(post) dependencies
  • From: John Pye <john@xxxxxxxxxxxxxxxxxx>
  • Date: Sun, 19 Aug 2007 18:12:24 +1000
  • Message-id: <46C7FB68.8030101@xxxxxxxxxxxxxxxxxx>
Hi all

I am seeing some strange behaviour in the OpenSUSE Build Service with
regard to post-install dependencies in RPM distros, specifically Fedora.

My ASCEND package includes a 'Requires(post)' dependency on
'desktop-file-utils'. The ASCEND package builds fine, but when I use
Build Service to build a package that *depends on* ASCEND (namely my
package called freesteam), I see an error at the time when Build Service
is installing ASCEND, which says "/var/tmp/rpm-tmp.98401: line 1:
update-desktop-database: command not found".

After that point, I seem to get further strange behaviour to do with my
ASCEND package; I am not sure if it is a result of the above error, or
another problem. But my package builds fine on my local machine with no
such errors.

Any thoughts?

Cheers
JP

Current state of these packages is at:
http://build.opensuse.org/project/show?project=home%3Ajdpipe
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups