Mailinglist Archive: opensuse-buildservice (366 mails)

< Previous Next >
[opensuse-buildservice] Re: Problem building zaptel
  • From: Vittorio Manfredini <vittorio@xxxxxxxxxx>
  • Date: Wed, 15 Aug 2007 10:41:14 +0200
  • Message-id: <20070815104114.px4lrtaj7ook84ws@xxxxxxxxxxxxxx>

I found the solution !!

Ther is a small fix to the zaptel Makefile in the xpp-utils install section (will try to install in /usr/sbin instead of %buildroot/usr/sbin)
and when try to do a make you have to specify this variable :

in the %build section

for flavor in %flavors_to_build; do
make %{?_smp_mflags} libdir=%{_libdir} KSRC=/usr/src/linux-obj/%_target_cpu/$flavor
done

in the %install section
for flavor in %flavors_to_build; do
%{__make} install \
    INSTALL_PREFIX="%{buildroot}" \
    ROOT_PREFIX="%{buildroot}" LIBDIR="%{_libdir}" \
    KSRC=/usr/src/linux-obj/%_target_cpu/$flavor
done

Remember that the new zaptel install some different file so you have to put it in the %files section.

I gave a look to your project and the difference is that I don't patch the zaptel source with bristuff I prefer the mISDN driver (I will build it soon as rpm).


----- Messaggio da listuser@xxxxxxxxxxxxxx ---------
    Data: Wed, 15 Aug 2007 08:50:50 +0300
      Da: Peter Nixon <listuser@xxxxxxxxxxxxxx>
Rispondi-A:Peter Nixon <listuser@xxxxxxxxxxxxxx>
 Oggetto: Re: Problem building zaptel
       A: Vittorio Manfredini <vittorio@xxxxxxxxxx>
      Cc: opensuse-buildservice@xxxxxxxxxxxx


Yes. But this step is not possible and should not be necessary on the build
service..

Cheers

Peter

On Wed 15 Aug 2007, Vittorio Manfredini wrote:
I did not understand the problem on the buildservice.

With the same files I was able to build the zaptel rpms on a real
opensuse 10.2 withouth any problem.

The only action that I have to do before starting build the rpms was
to go on /usr/src/linux and do a make cloneconfig ; make

thi generate all the file necessary to build the zaptel package.




----- Messaggio da listuser@xxxxxxxxxxxxxx ---------
     Data: Tue, 14 Aug 2007 21:46:32 +0300
       Da: Peter Nixon <listuser@xxxxxxxxxxxxxx>
Rispondi-A:Peter Nixon <listuser@xxxxxxxxxxxxxx>
  Oggetto: Re: Problem building zaptel
        A: opensuse-buildservice@xxxxxxxxxxxx
       Cc: Vittorio Manfredini <vittorio@xxxxxxxxxx>

> On Mon 13 Aug 2007, Vittorio Manfredini wrote:
>> I generate all the necessary files to build the zaptel package and if
>> I try to build it
>> localy on my machine it works, but on the web buildservice I have the
>> following error :
>>
>> /usr/bin/make -C /usr/src/linux
>> SUBDIRS=/usr/src/packages/BUILD/zaptel-1.4.4 modules
>> make[2]: Entering directory `/usr/src/linux-2.6.18.2-61'
>>
>> ERROR: Kernel configuration is invalid.
>> include/linux/autoconf.h or include/config/auto.conf are missing.
>> Run 'make oldconfig && make prepare' on kernel src to fix it.
>>
>>
>> WARNING: Symbol version dump /usr/src/linux-2.6.18.2-61/Module.symvers
>> is missing; modules will have no dependencies and modversions.
>>
>> CC [M] /usr/src/packages/BUILD/zaptel-1.4.4/pciradio.o
>> In file included from include/asm/smp.h:19,
>> from include/linux/smp.h:18,
>> from include/linux/sched.h:63,
>> from include/linux/module.h:9,
>> from /usr/src/packages/BUILD/zaptel-1.4.4/pciradio.c:48:
>> include/asm/io_apic.h: In function 'io_apic_read':
>> include/asm/io_apic.h:180: error: implicit declaration of function
>> 'HYPERVISOR_physdev_op'
>> In file included from include/linux/smp.h:18,
>> from include/linux/sched.h:63,
>> from include/linux/module.h:9,
>> from /usr/src/packages/BUILD/zaptel-1.4.4/pciradio.c:48:
>> include/asm/smp.h: In function 'hard_smp_processor_id':
>> include/asm/smp.h:76: error: implicit declaration of function
>> 'GET_APIC_ID' include/asm/smp.h:76: error: 'APIC_BASE' undeclared
>> (first use in this function)
>> include/asm/smp.h:76: error: (Each undeclared identifier is reported
>> only once include/asm/smp.h:76: error: for each function it appears
>> in.) include/asm/smp.h:76: error: 'APIC_ID' undeclared (first use in
>> this function) include/asm/smp.h: In function
>> 'logical_smp_processor_id': include/asm/smp.h:134: error: implicit
>> declaration of function 'GET_APIC_LOGICAL_ID'
>> include/asm/smp.h:134: error: 'APIC_BASE' undeclared (first use in
>> this function)
>> include/asm/smp.h:134: error: 'APIC_LDR' undeclared (first use in this
>> function)
>> make[3]: *** [/usr/src/packages/BUILD/zaptel-1.4.4/pciradio.o] Error 1
>> make[2]: *** [_module_/usr/src/packages/BUILD/zaptel-1.4.4] Error 2
>> make[2]: Leaving directory `/usr/src/linux-2.6.18.2-61'
>> make[1]: *** [modules] Error 2
>> make[1]: Leaving directory `/usr/src/packages/BUILD/zaptel-1.4.4'
>> make: *** [all] Error 2
>> error: Bad exit status from /var/tmp/rpm-tmp.23820 (%build)
>>
>>
>> Seem that the kernel source is installed but not correctly configured
>> (make cloneconfig /
>> make).
>>
>> What I have to do to solve this problem ?
>
> Yep. I am having the same problem with the latest zaptel and factory
> kernel in network:telephony/zaptel
>
> I do plan on spending some more time on it but am a bit swamped at
> present. I am not sure where your package lives, but I would be happy
> for you to help out with my "official" one.
>
> Cheers
>
> --
>
> Peter Nixon
http://peternixon.net/

----- Fine del messaggio da listuser@xxxxxxxxxxxxxx -----



----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.



--

Peter Nixon
http://peternixon.net/



----- Fine del messaggio da listuser@xxxxxxxxxxxxxx -----



----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >