Mailinglist Archive: opensuse-buildservice (181 mails)

< Previous Next >
[opensuse-buildservice] Qt4 conflicts in SUSE Linux 10.0 (10.1)
  • From: Nikolay Derkach <nderkach@xxxxxxxxx>
  • Date: Fri, 27 Jul 2007 14:21:50 +0400
  • Message-id: <200707271421.51118.nderkach@xxxxxxxxx>
Hello,

I've found some Qt4 issues in SL 10.1(10.0) repositories. This happens in 
projects which have aggregated libqt4 from KDE:Qt.

For some reason default Qt (qt-4.1) installs in addition to required libqt4 
(4.3) and this causes conflicts as follows:

---
installing qt-devel-4.1.0-29
installing libqt4-x11-4.3.0-75.1
file /usr/lib/libQtDesigner.so.4 from install of libqt4-x11-4.3.0-75.1 
conflicts with file from package qt-devel-4.1.0-29
file /usr/lib/libQtDesignerComponents.so.4 from install of 
libqt4-x11-4.3.0-75.1 conflicts with file from package qt-devel-4.1.0-29 
---

Just few examples of qt4 packages:

http://build.opensuse.org/package/show?package=libqca2&project=server%3Amessaging
http://build.opensuse.org/package/show?package=sqliteman&project=KDE%3ACommunity

-- 
Regards, Nikolay Derkach
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages