Mailinglist Archive: opensuse-buildservice (181 mails)

< Previous Next >
Re: [opensuse-buildservice] Problems building using xmkmf -- looking for suggestions
  • From: Plinnell <mrdocs@xxxxxxxxxxxx>
  • Date: Thu, 26 Jul 2007 15:53:27 +0200
  • Message-id: <200707261553.28396.mrdocs@xxxxxxxxxxxx>
On Thursday 26 July 2007, John Pye wrote:
> Hi all
>
> I have been stumped by these errors I'm getting when attempting to
> build a 'tightvnc' package on Build Service. This package builds
> fine on my local Fedora 7 system, but fails on the Build Service,
> with the same error on Fedora 7 as well as Mandriva 2006. Perhaps I
> am missing a build-time dependency, or something like that?
>
> |+ xmkmf -a
>
> imake -DUseInstalled -I/usr/share/X11/config
> make Makefiles
> making Makefiles in libvncauth...
> make[1]: Entering directory `/usr/src/redhat/BUILD/vnc_unixsrc'
> Imakefile.c:34: error: Imake.tmpl: No such file or directory
> imake: Exit code 1.
>
> |If there is someone here with experience building X11
> | applications, I'd
>
> really appreciate some suggestions on what I can try to fix this.
>
> The package and build logs are here:
> http://build.opensuse.org/package/show?package=tightvnc&project=hom
>e%3Ajdpipe
>
> Cheers
> JP
> -------------------------------------------------------------------

Hi,

Try adding xorg-x11-util-devel for Suse and the equivalent for 
Fedora/Mandriva to the Build Requires.

Note you have a whole pile of BuildRequires for Fedora, but not for 
Suse or Mandriva.

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups
References