Mailinglist Archive: opensuse-buildservice (209 mails)

< Previous Next >
Re: [opensuse-buildservice] Problems with "expansion error: nothing provides"
  • From: Michael Schroeder <mls@xxxxxxx>
  • Date: Mon, 11 Jun 2007 12:23:53 +0200
  • Message-id: <20070611102353.GA10357@xxxxxxx>
On Sun, Jun 10, 2007 at 11:59:18PM -0500, Steven Harrison wrote:
> In the process of building RPMs for OpenSER 1.2.1 on openSUSE 10.2
> x86_64.... I have modified the spec file with all of the required bits
> for my make. 
> 
> Copied all of the RPMS to a local folder (/usr/sources)... 
> 
> One of the bits is not part of the standard openSUSE RPMs package on the
> DVD - unixODBC-devel - so I found a SUSE compatible x86_64 RPM and put
> it into the x86_64 folder under /suse/x86_64 in my local sources folder.
> 
> 
> Well for the life of me I can't make build recognize that the stupid RPM
> is there! 

That sounds like this is abuild the "build" package, not the
opensuse buildservice. Anyway, you have to put your local
directory containing the rpms in the package search path, i.e.
try something like

    build --rpms <localdir>:<path_to_DVD> ...

Cheers,
  Michael.

-- 
Michael Schroeder                                   mls@xxxxxxx
SUSE LINUX Products GmbH, GF Markus Rex, HRB 16746 AG Nuernberg
main(_){while(_=~getchar())putchar(~_-1/(~(_|32)/13*2-11)*13);}
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
References