Mailinglist Archive: opensuse-buildservice (354 mails)

< Previous Next >
Re: [opensuse-buildservice] build issue: log4net on fedora_extra_6
  • From: "Manuel Arostegui" <manuel@xxxxxxxxxxxxxx>
  • Date: Thu, 15 Feb 2007 12:04:58 +0100 (CET)
  • Message-id: <52072.87.217.44.5.1171537498.squirrel@xxxxxxxxxxxxxxxxxxxxxx>
On Thu, February 15, 2007 11:51, Jan-Simon Möller wrote:
> Hi list!
>
>
> I've got problems building log4net on fedora_extra_6 as target (all suse
> builds are ok!). My Project is home:/dl9pf
>
> Here is the error:
>
>
>
>
> Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.45977
> + umask 022
> + cd /usr/src/redhat/BUILD
> + cd log4net-1.2.9
> + export LC_CTYPE=en_US.UTF-8
> + LC_CTYPE=en_US.UTF-8
> +
> mcs -out:log4net.dll -keyfile:/usr/src/redhat/SOURCES/log4net.key /target:library /r:System.dll
> /r:System.Data.dll /r:System.Web.dll
>
>
> [...]
>
>
> src/LogicalThreadContext.cs src/LogManager.cs src/MDC.cs src/NDC.cs src/ThreadContext.cs
>
> ** (/usr/lib/mono/1.0/mcs.exe:1760): CRITICAL **: _wapi_shm_file_open: shared
> file [/.wapi/shared_data-build05-Linux-i686-308-10-0] open error: No such file or directory
>
> ** (/usr/lib/mono/1.0/mcs.exe:1760): CRITICAL **: _wapi_shm_attach: shared
> file [/.wapi/shared_data-build05-Linux-i686-308-10-0] open error
>
> ** ERROR **: file shared.c: line 313 (_wapi_shm_semaphores_init): assertion
> failed: (tmp_shared != NULL)
> aborting...
>
> =================================================================
> Got a SIGABRT while executing native code. This usually indicates
> a fatal error in the mono runtime or one of the native libraries used by your application.
> =================================================================
>
>
> Stacktrace:
>
>
>
> Native stacktrace:
>
>
> /usr/bin/mono(mono_handle_native_sigsegv+0xe6) [0x815fc26]
> [0xffffe600]
> [0xffffe402]
> /lib/libc.so.6(gsignal+0x50) [0xb7ce4d40]
> /lib/libc.so.6(abort+0x101) [0xb7ce6591]
> /lib/libglib-2.0.so.0(g_logv+0x4d2) [0xb7e8dc92]
> /lib/libglib-2.0.so.0(g_log+0x29) [0xb7e8dcc9]
> /lib/libglib-2.0.so.0(g_assert_warning+0x76) [0xb7e8dd46]
> /usr/bin/mono [0x8112592]
> /usr/bin/mono [0x8108902]
> /usr/bin/mono(mono_once+0x49) [0x80fffb9]
> /usr/bin/mono [0x8108abc]
> /usr/bin/mono [0x8111589]
> /usr/bin/mono(mono_thread_pool_init+0x93) [0x80bd183]
> /usr/bin/mono(mono_runtime_init+0x21) [0x80f0da1]
> /usr/bin/mono [0x812bad3]
> /usr/bin/mono(mono_main+0x32e) [0x805c83e]
> /usr/bin/mono [0x805c002]
> /lib/libc.so.6(__libc_start_main+0xdc) [0xb7cd1f2c]
> /usr/bin/mono [0x805bf51]
> /var/tmp/rpm-tmp.45977: line 230: 1760 Aborted
>
>
> [...]
>
>
> error: Bad exit status from /var/tmp/rpm-tmp.45977 (%build)
>
>
>
> RPM build errors:
> Bad exit status from /var/tmp/rpm-tmp.45977 (%build)
> md: stopping all md devices.
> System halted.
>
>
>
> I've no new idea ...

More or less the same for me using build09.
By the way, FC4 and FC5 works fine with this package.
/.build/build: line 498: 1574 Segmentation fault cp -p $MYSRCDIR/*
$BUILD_ROOT$TOPDIR/SOURCES/
/.build/build: line 498: 1577 Segmentation fault cp -p
$BUILD_ROOT/root/.rpmmacros $BUILD_ROOT/home/abuild/.rpmmacros
/.build/build: line 498: 1579 Segmentation fault cp -p
$BUILD_ROOT/root/.rpmrc $BUILD_ROOT/home/abuild/.rpmrc
-----------------------------------------------------------------
I have the following modifications for yixue_console.spec:
53c53
< Release: %{release}
---
> Release: 1.1
-----------------------------------------------------------------
----- building yixue_console.spec (user abuild)
-----------------------------------------------------------------
-----------------------------------------------------------------
error: File /usr/src/redhat/SOURCES/yixue_console.tar.gz: No such file or
directory

All the best
Manuel.

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
References