Mailinglist Archive: opensuse-buildservice (354 mails)

< Previous Next >
[opensuse-buildservice] Local BS installation :: expansion errors
  • From: "Srinidhi B" <srinidhi@xxxxxxxxxx>
  • Date: Wed, 14 Feb 2007 00:36:57 -0700
  • Message-id: <45D309710200005500007FE7@xxxxxxxxxxxxxxxxxxxxxxx>
Hi,

I've installed BS on my local machine. When I trigger a build, I get the
following message (I'm running "./bs_sched i586" manually)

package loop
- home:srinidhi/SUSE_Linux_10.1 (spec)
expanding dependencies
sorting 2 packages
- ifolder3 (no source uploaded)
- simias (spec)
expansion errors:
nothing provides compat-libstdc++
nothing provides e2fsprogs
nothing provides e2fsprogs-devel
nothing provides gcc-c++
nothing provides gconf2
nothing provides glib2
nothing provides glib2-devel
nothing provides libflaim
nothing provides libflaim-devel
nothing provides libstdc++
nothing provides libstdc++-devel
nothing provides libxml2
nothing provides libxml2-devel
nothing provides log4net
nothing provides mono-core
nothing provides mono-data
nothing provides mono-devel
nothing provides mono-web
nothing provides pkgconfig
nothing provides xsp
nothing provides autoconf
nothing provides automake
nothing provides binutils
nothing provides bzip2
nothing provides db
nothing provides gcc
nothing provides gdbm
nothing provides gettext
nothing provides glibc
nothing provides libtool
nothing provides ncurses
nothing provides perl
nothing provides rpm
nothing provides zlib
building: 0, notready: 0
waiting for an event...

All these packages are mentioned in the "BuildRequires" tag in the spec
file.

If I comment BuildRequires, then I get this:
package loop
- home:srinidhi/SUSE_Linux_10.1 (spec)
expanding dependencies
sorting 2 packages
- ifolder3 (no source uploaded)
- simias (spec)
expansion errors:
nothing provides autoconf
nothing provides automake
nothing provides binutils
nothing provides bzip2
nothing provides db
nothing provides gcc
nothing provides gdbm
nothing provides gettext
nothing provides glibc
nothing provides libtool
nothing provides ncurses
nothing provides perl
nothing provides rpm
nothing provides zlib
building: 0, notready: 0
waiting for an event...

I've the following directory structure under /srv/obs/build:

# tree -L 5
.
|-- SUSE:SL-10.0
| `-- standard
| `-- i586
| |-- :full
| | `-- i586
| `-- :full.cache
|-- SUSE:SL-10.1
| `-- standard
| `-- i586
| |-- :full
| | |-- ARCHIVES.gz
| | |-- COPYING
| | |-- COPYING.de
| | |-- COPYRIGHT
| | |-- COPYRIGHT.de
| | |-- ChangeLog
| | |-- INDEX.gz
| | |-- README
| | |-- README.BETA
| | |-- README.DOS
| | |-- boot
| | |-- content
| | |-- content.asc
| | |-- content.key
| | |-- control.xml
| | |-- directory.yast
| | |-- docu
| | |-- gpg-pubkey-0dfb3188-41ed929b.asc
| | |-- gpg-pubkey-307e3d54-44201d5d.asc
| | |-- gpg-pubkey-3d25d3d9-36e12d04.asc
| | |-- gpg-pubkey-7e2e3b05-44748aba.asc
| | |-- gpg-pubkey-9c800aca-40d8063e.asc
| | |-- gpg-pubkey-a1912208-446a0899.asc
| | |-- ls-lR.gz
| | |-- media.1
| | |-- pubring.gpg
| | `-- suse
| |-- :full.cache
| |-- :packstatus
| |-- :repo
| `-- :repodone
|-- home:srinidhi
| `-- SUSE_Linux_10.1
| `-- i586
| |-- :packstatus
| |-- :repo
| `-- :repodone
`-- openSUSE:10.2
`-- standard
`-- i586
|-- :full
|-- :full.cache
|-- :packstatus
|-- :repo
`-- :repodone

Could anyone please point out what I'm doing wrong?

Thanks,
Srinidhi.

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >