Mailinglist Archive: opensuse-buildservice (354 mails)

< Previous Next >
Re: [opensuse-buildservice] expansion errors for SUSE_Linux_10.0 + SUSE_Linux_10.1
  • From: Martin Mohring <martin.mohring@xxxxxxxxx>
  • Date: Tue, 13 Feb 2007 20:21:44 +0100
  • Message-id: <45D20FC8.4020109@xxxxxxxxx>
Michael Schroeder wrote:
> On Tue, Feb 13, 2007 at 07:42:52PM +0100, Martin Mohring wrote:
>
>> Hi,
>>
>> when currently building my Package"CrossToolchain:sh4/cross-sh4-binutils",
>> I get expansion errors for SUSE_Linux_10.0 + SUSE_Linux_10.1 only:
>>
>> buildinfo is broken... it says:
>> expansion error: nothing provides linux-kernel-headers needed by glibc-devel
>>
>
> That's because your "cross-sh4-glibc-bootstrap" glibc package
> contains this requirement. Why do you need this "bootstrap"
> package?
>
> Cheers,
> Michael.
>
>
I have to bootstrap a cross toolchain in 3 iterations (without target
binaries):

1. provide cross-binutils
2. provide cross-kernel-headers
3. provide cross-glibc-headers

4. build empty cross-gcc
5. build initial glibc without programs

6. build real cross-gcc
7. build real cross-glibc

So my naming for the packages is:

1. cross-sh4-binutils
2. cross-sh4-kernel-headers
3. cross-sh4-glibc-headers
4. cross-sh4-bootstrap-gcc
5. cross-sh4-glibc-bootstrap
6. cross-sh4-gcc
7. cross-sh4-glibc

Packages 6+7 are not yet finished, Richard G√ľnther started with them using
an old version of the packages (Project: "Base"). Now we have decided to
switch to the openSUSE:Factory codebase.

BTW: I generate the cross-sh4-*.spec file from the templates by
pre_checkin.sh scripts, as was the procedure logs since in
original binutils Package.

Martin
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups