Mailinglist Archive: opensuse-buildservice (354 mails)

< Previous Next >
Re: [opensuse-buildservice] Failed to add repository from build service
  • From: "Dr. Peter Poeml" <poeml@xxxxxxx>
  • Date: Tue, 13 Feb 2007 08:43:29 +0100
  • Message-id: <20070213074329.GO15060@xxxxxxx>
On Thu, Feb 08, 2007 at 11:26:18AM +0100, Adrian Schröter wrote:
> Am Donnerstag 08 Februar 2007 10:28:10 schrieb Dirk Stoecker:
> > Hello,
> >
> > I failed to add OpenSUSE build service repositories to two different
> > OpenSUSE 10.2 servers.
> >
> > repositories are "home:dstoecker" and "science"
> >
> > Attached is a y2log I tried with following URL
> > ftp://ftp.gwdg.de/pub/opensuse/repositories/home:/dstoecker/openSUSE_10.2
> >
> > It seems there are some problems with the key file. I had no trouble to
> > add the same source on my desktop system with OpenSUSE10.2. The only
> > difference is that the 2 servers have no desktop system installed and I
> > used yast commandline version (thought there should be no difference
> > between GUI and commandline version, shouldn't it).
> >
> > The question are:
> > - is that a build-service problem
> > - is this an yast problem I should report for openSUSE10.2
> >
> > Additional note: Had no problem on a 10.1 server.
>
>
> It is not a bug, it is a feature ...
>
> YaST in 10.2 does validate the repository meta data, which means that it
> accepts only repositories which are signed with an accept key. When you
> import the key into the rpm database, it should get accepted.

It rather looks like a bug... which is fixed since yesterday in Factory.
https://bugzilla.novell.com/show_bug.cgi?id=240771

Regards,
Peter
--
SUSE LINUX Products GmbH Bug, bogey, bugbear, bugaboo:
Research & Development A malevolent monster (not true?);
Some mischief microbic;
What makes someone phobic;
The work one does not want to do.
From: Chris Young (The Omnificent English Dictionary In Limerick Form)
< Previous Next >