Mailinglist Archive: opensuse-buildservice (227 mails)

< Previous Next >
Re: [opensuse-buildservice] obs-server README.SETUP example wrong?
  • From: Andreas Bauer <abauer@xxxxxxx>
  • Date: Tue, 30 Jan 2007 17:39:58 +0100
  • Message-id: <200701301739.58160.abauer@xxxxxxx>
On Monday, 29. January 2007 19:30, Robert Schiele wrote:
> On Mon, Jan 29, 2007 at 07:24:00PM +0100, Peter Poeml wrote:
> > Hi,
> >
> > there is this example in /usr/share/doc/packages/obs-api/README.SETUP
> > (strings adjusted):
> >
> > <project name="SUSE_Linux_10.1">
> > <repository status='disabled' name='standard'>
> > <arch>ppc</arch>
> > </repository>
> > <title>the SUSE_Linux_10.1 distribution</title>
> > <description></description>
> > </project>
> >
> > However, it doesn't work with my buildservice instance, it gives an
> > internal server error.
> >
> > This works though:
> >
> > <project name="SUSE_Linux_10.1">
> > <title>SUSE_Linux_10.1 distribution</title>
> > <description>SUSE_Linux_10.1 distribution.</description>
> > <person userid="Admin" role="maintainer"/>
> > <repository name="standard">
> > <arch>ppc</arch>
> > </repository>
> > </project>
> >
> > What's wrong? Am I confused?
>
> <repository> cannot have a "status" attribute.

Also the order of elements below project is important. Correct order is title,
description, person, repository.

> Robert

--
Andreas Bauer - Novell - SUSE Internal Tools
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >